Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2005, 12:04 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,164
Question Injection pump ?

Recently, I have noticed a vibration that has taken a turn for the worse. This problem would be very random a couple of months ago but is constant now.

The problem is definitely rpm related. I notice it at about 1700-1900 rpm. Below and above that rate it smooths out. Also, I am hearing very severe nailing, and smoke, at lower rpms especially at cold idle. At higher rpms, such as highway speeds, it is not as bad but I do seem to notice a "missing" especially with the car loaded with passengers.There is no increase in oil consumption or blow by.

I am picking up a mechanics stethescope to try and do a little more pinpointing. I tried a large screwdriver but with its decreased sensitivity, I am unsure what "normal" sounds are.

From scratching my head and reading about this, I am thinking it may be the IP. I am suspectiing maybe governor flyweights or something in that area. How difficult is it to access that part of the IP? Any other thoughts as to what I should check?
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
  #2  
Old 02-07-2005, 04:22 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
I would think that it's more likely an injector than the pump. You could find which cylinder it is (either by listening or cracking the lines open) and pull that injector..... maybe swap it with one that works and see if the problem moves to that cylinder. Or just have them all rebuilt.
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #3  
Old 02-07-2005, 11:44 PM
Registered User
 
Join Date: Jun 2004
Location: West of Ft. Worth. TX
Posts: 4,164
Question

Would injectors cause vibration at a specific rpm like that? With that in mind, I suspected the problem to be "deeper". I guess with the high mileage, I sometimes expect the worse. Have you witnessed similar symptoms at some time?

As soon as I can get ahold of new heat shields, I will take a look at the injectors.
__________________
Sam

84 300SD 350K+ miles ( Blue Belle )
Reply With Quote
  #4  
Old 02-07-2005, 11:49 PM
Banned
 
Join Date: May 2002
Location: Blue Point, NY
Posts: 25,396
Funny you should mention this. The 603 seems to exhibit the same phenomena. Around 2000 rpm, under load, it has just a bit of vibration. It goes away at 2300 and is not apparent at light loads at any speeds.

Quite strange. Not serious enough to attempt to isolate, however.
Reply With Quote
  #5  
Old 02-08-2005, 08:30 AM
Geezer
 
Join Date: Aug 2000
Location: Holland, MI
Posts: 1,316
Nailing and smoke = injector system.

I think the IP itself, or its governor system, is the last place to look.

First things to check and test.

Valve clearances. Not difficult or expensive, couldn't hurt, and could tell a story.

Injector spray pattern and pop pressure. Unbalance in injectors can cause unbalance in firing and uneven torque pulsing, or vibration.

Delivery valve seal and pressure build up in injector line. Failure to build to 'pop' pressure rapidly can cause late injection, and if it's in one or two injectors only, the above unbalance in firing and torque pulsing.

Best Regards,
Jim
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gasket for Injection Pump gilbertb1 Diesel Discussion 10 04-07-2005 06:04 AM
Removing injection pump in a 350SD dhillman Tech Help 2 02-09-2005 05:32 AM
Removing Injection Pump in a 1991-350SD dhillman Diesel Discussion 11 02-08-2005 10:41 PM
Injection pump leak 240Demon Diesel Discussion 5 12-23-2003 06:31 PM
Car smokes pretty bad under hard boost 87300SDLTurbo Tech Help 7 11-27-2002 05:47 AM



All times are GMT -4. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page