Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-08-2005, 03:20 PM
Registered User
 
Join Date: Nov 2003
Location: California
Posts: 37
Question A/C Relay problem? 86 300SDL

86 300SDL: A/C continues to be a problem. Replaced the compressor/clutch, expansion valve, receiver/drier, relay, early last summer. The A/C switch assembly may be origional and I have not replaced it as it appears to operate ok. Problem appears to settle around the A/C relay (KAE) located on the fire wall, about the size of a pack of cigs. close to the MC. When removing the relay, the compressor/clutch wants to kick in and does sometimes for a few seconds then cuts out. Relay was replaced again last fall and now appears to be failing again. Removing the relay and then replacing it starts the clutch to kick in and then kick out. I acts like there is a short in the system?
I do not want to continue replacing the relay every six months. Any ideas on what would cause this? It has become very frustrating.
Thanks,
Ron
Reply With Quote
  #2  
Old 03-08-2005, 03:53 PM
Registered User
 
Join Date: Feb 2004
Location: Ontario, Canada
Posts: 482
Not sure if this is related, but both the A/C Compressor Clutch and the Auxilliary Water Pump are fed from Fuse #5. If the Water Pump is seized then maybe this is causing problems with the A/C relay. I think that the ACC is fed from the same source so that may be affected as well. It might be worth disconnecting the Aux.Water Pump just to see if it makes any difference.

Good Luck
__________________
1991 M-B 560SEL Arctic White/Grey 99,000 Miles
1987 M-B 300SDL Ivory/Palomino 229,000 Miles (sold but never forgotten)
2006 Volvo XC70 Blue/Beige
1999 Porsche Boxster Arena Red/Savanna Beige
1972 Porsche 911 Viper Green/Black
Reply With Quote
  #3  
Old 03-08-2005, 04:02 PM
billrei's Avatar
W109, Floating on air!!
 
Join Date: Jan 2005
Location: Goleta, CA
Posts: 556
You may want to do a search/post on this site: http://www.aircondition.com/wwwboard/

Deals strictly with AC problems. Some people there really know their *****.
__________________
Bill Reimels
Now down to one:
1972 300SE 3.5 W109 (Euro delivery)
Reply With Quote
  #4  
Old 03-08-2005, 07:39 PM
Registered User
 
Join Date: Apr 2004
Location: Deptford NJ.
Posts: 55
A/C problem

Ron, Does your tach shut down at the same time as your a/c. If it does check a plug that runs on the right side of the battery and near the relay it corodes and must be fixed. You will have to remove the battery to fix. Good luck
__________________
Pete.
__________________
Pete.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W140 Fuel Pump problem - relay or pump? oestek Tech Help 1 01-27-2005 01:35 PM
Bad A/C relay again, in less than 6 months! J.HIDALGO Tech Help 10 08-28-2003 05:52 PM
a/c problem in C230K BillH Tech Help 12 05-05-2003 04:31 PM
240d glow plug relay problem? ajb Diesel Discussion 2 11-14-2001 04:18 PM



All times are GMT -4. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page