Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2003, 12:46 PM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
a/c problem in C230K

My wife reports a recent problem with the a/c in 1999 C230K - I will try to relay her description and hope it provides enough info for replies. When the a/c is on and the fan is blowing, an occasional "whistle" sound occurs as if a vent is partially closed or something is impeding air flow. Also, occasionally the fan blower will continue to operate at the same speed after the fan control has been turned up. The fan speed will then increase shortly therafter to the correct speed. Is this a problem with the the fan motor only, or more? Thanks for your advice before I take the car to my indie.
Reply With Quote
  #2  
Old 05-01-2003, 12:52 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
cabin filter


blower regulator




Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #3  
Old 05-01-2003, 12:56 PM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
Thanks Joe for prompt reply. Can you give me an idea as to repair cost?
Reply With Quote
  #4  
Old 05-01-2003, 02:23 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
nope, too many variables in labour and parts markup.


Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #5  
Old 05-03-2003, 02:22 AM
Registered User
 
Join Date: Sep 2002
Location: SEATTLE
Posts: 239
C230K AC

I had a 2002 C230K as a service rental this week and I noticed that the fan did indeed fail to respond immediately to the fan speed switch. As they say, this is probably a feature, not a bug.

Is your car out of warranty? When was the last time you replaced the cabin air filter, by the way? Annually is not too often.
Reply With Quote
  #6  
Old 05-05-2003, 10:52 AM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
Roger - I had a service approximately four months ago and the print-out shows the cabin filter was replaced. To make sure, I checked it myself the other night and it appears new and clean. A whistling sound is still heard off and on when the a/c is on or when just the fan is blowing. The fan speed problem is also an occasional deal. I am scheduled to take it in to my indie on Wednesday. He stated the problem sounded like the cabin filter and/or the regulator and, if so, it could cost $300 - $400. I am not enough of a DYI-er to tackle something of that nature - so guess I'll get the checkbook ready!
Reply With Quote
  #7  
Old 05-05-2003, 11:11 AM
Registered User
 
Join Date: Dec 2002
Posts: 48
It's not too hard to replace the blower motor/regulator yourself. If you've replaced the cabin filter, you can do the blower motor regulator. What's worked for me for the last 8000 miles has been to clean out the motor, and put a little grease on the bottom of the motor, and that has pretty much killed the noise.
Reply With Quote
  #8  
Old 05-05-2003, 11:34 AM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
Thanks C220 - can you give me a brief run-down on how to get to the motor/regulator?
Reply With Quote
  #9  
Old 05-05-2003, 04:14 PM
Registered User
 
Join Date: Dec 2002
Posts: 48
(These steps worked on my 95 C220, I think that it should be substantially similar for your '99, as they're both W202s. But if anyone has better information, please correct me)

Really wish I had a digital camera to help step you through this process.

First, place a drop cloth on the passenger footwell floor to catch any falling screws or dirt.

Look on the passenger front side footwell.

On the left hand side of the footwell, there's an air vent. Remove that. (I think there's a plastic phillips-type connector that you need to turn)

Then, on the top of the footwell, there's a large plastic panel that you need to remove. It has three phillips screws that you need to take off to get this panel off.

After removing this panel, look up (a flashlight might help). There should be two compartments that are secured by clips. The long skinnier one is the cabin filter. (BTW, it might be a good idea to change this at the same time that you change the blower motor- this might eliminate the problem-- at the very least, you'll have a clean filter in place)

The squarish one is the blower motor assembly. unclip the cover (I think there are 2 or 3 slide-type clips at the front), and there's the blower motor. It unscrews out (I think that there's 4 torx screws, but they might be phillips- if its torx, I think that it's a T-23 or T-22 size one- Allen keys might also work) and there's a single electrical connector that you disconnect and there's your motor.

When you have it out, might not be a bad idea to reach in and clean out some of the crud in the general area.

When I cleaned out my blower motor, a toothbrush was very helpful in getting grit and grime loose.

If you reconnect the motor after cleaning and don't have any noise when it's spinning, *retest* it when it is back in its cavity before sealing it all up-- you might find that it makes no noise when you're holding it in your hand, but it will make noise when it is back in the hole.

Worst case is after all this, if it still makes noise, you know how to put in your new motor without going to the dealer.

Note: Be very patient when you're working with the clips for the first time-- the first time I did it, I swore more than a civillian should during peacetime.

Good Luck!
Reply With Quote
  #10  
Old 05-05-2003, 04:39 PM
Registered User
 
Join Date: Sep 2002
Location: SEATTLE
Posts: 239
C230K AC stuff

Wait a minute here. We may not be talking about the same car. I was referring to the W203 C230 coupe with manual AC, not the earlier four door with a similar nomenclature. If it the car is a W202, then forget everything I said.
Reply With Quote
  #11  
Old 05-05-2003, 04:40 PM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
Thanks again 95c220 - I'll give it a try. I felt like I needed a chiropractor after checking the cabin filter - I could not find a comfortable position to work. A little discomfort is worth saving $400.
Reply With Quote
  #12  
Old 05-05-2003, 05:21 PM
Registered User
 
Join Date: Dec 2002
Posts: 48
You might also want to check out this thread before starting. Not sure of how it is on a '99, if the regulator is integrated onto the blower motor. (If it is, still not sure if you want to replace just the regulator, or the whole shebang, if the motor's sqeaking)

Regulator Thread
Reply With Quote
  #13  
Old 05-05-2003, 05:31 PM
Registered User
 
Join Date: Nov 2002
Location: Oklahoma City. OK
Posts: 38
I assume its integrated - I checked the Fastlane parts catalog and it only lists a blower motor - no separate listing for a regulator.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page