Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2006, 04:55 PM
Panzermann's Avatar
How did I get here?
 
Join Date: Mar 2006
Location: Arizona
Posts: 232
Transmission issue in 1985 300D

So, I've developed a transmission issue in Goldbug. Goldbug is a 1985 300D chassis (California emissions) with a 1983 300SD engine (not California emissions). The transmission is the original one from the 1985, California emissions (which is apparently different than that for non-California emissions for the 1985 model year). When I reassembled the engine with the transmission, two things of note happened/occurred:
1) I replaced the black modulator valve of the California emissions with the Green on for the federal emissions, because I figured that the engine was now effectively a Federal emissions car. This info is included for completeness.
2) I broke the front hydraulic pump, which then had to be replaced with a used one, after I sought professional help.

Car drove away well from the mechanic's place, albeit with a cloud of smoke which resolved with a valve adjustment, rebuilt injectors, new fuel filters and draining the fuel tank.

So, I proudly drove Goldbug over to take its Arizona emissions test, which measures opacity of the exhaust. She passed with flying colors, scoring a 1.1%, with 30% passing. Hooray!

On the way back unfortunately (don't these posts always have this particular inflection point?), I stopped at a light. Car was driving great. Light turns green. I push down pedal. Car moves ahead, only slowly. Then car doesn't upshift. I manage to get across intersection, pull over, check transmission fluid, have to back up (which works fine, no problem), so I take off again. Car generally behaves as if transmission on last legs, maximum speed about 25 mph. A couple times, it seems to imperceptible upshift, allowing me to gradually accelerate to 40-45 mph, although I did not perceive upshift. I straggle home, park car in driveway and use other car for transport.

Next day, I start car, no forward gears, but reverse works fine, strong, no problem.

Any thoughts from anyone regarding problem, and also protocol to round up the ususal suspects, before I resort to professional help? Little thing or big bad dead transmission thing? In the words of Ben Stein in "Ferris Bueller's Day Off," "Anyone? Anyone?"
__________________
Der Panzermann und Fraulein Fahrvergnuegen

1991 420SEL 201K "The Big Blue One"
1985 300DT 205K chassis/285K engine nee California emissions "Goldbug"
1983 300TDT 255K "The Womble"
1983 300 DT 214K "Sea Sprite"-Rear-ended a truck
1983 300SD 285K "The Donor" Gave his life so that others can live
1980 500SL Euro 105K "Der Panzer"
Reply With Quote
  #2  
Old 05-20-2006, 05:03 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,085
Thumbs up

I recall something about the B2 piston causing problems such as this as the bands for 1 and 2 can't be applied...

It's not the pump as you have reverse.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #3  
Old 05-20-2006, 05:05 PM
Panzermann's Avatar
How did I get here?
 
Join Date: Mar 2006
Location: Arizona
Posts: 232
Quote:
Originally Posted by Hit Man X
I recall something about the B2 piston causing problems such as this as the bands for 1 and 2 can't be applied...

It's not the pump as you have reverse.
I concluded the same thing about the pump. In addition, this indicated that there was adequate fluid in the transmission (in addition to having seen it). Sounds like repair of this is likely to be beyond my technical capacity, though.
__________________
Der Panzermann und Fraulein Fahrvergnuegen

1991 420SEL 201K "The Big Blue One"
1985 300DT 205K chassis/285K engine nee California emissions "Goldbug"
1983 300TDT 255K "The Womble"
1983 300 DT 214K "Sea Sprite"-Rear-ended a truck
1983 300SD 285K "The Donor" Gave his life so that others can live
1980 500SL Euro 105K "Der Panzer"
Reply With Quote
  #4  
Old 05-20-2006, 05:07 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,085
Thumbs up

If it is that servo, it's just on the side of the case. If you can get the car jacked up enough to get under it to service the transmision, you should be able to do the servo.

Probably just held in with a snap ring and some o-rings. All they do is apply pressure to a band
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #5  
Old 05-20-2006, 05:43 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Transmission:

Check out the B2 piston threads.
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #6  
Old 05-20-2006, 06:31 PM
Panzermann's Avatar
How did I get here?
 
Join Date: Mar 2006
Location: Arizona
Posts: 232
Yes...

...that sure sounds like what happened, and sounds like a non-catastrophic failure, although I hust admit that its repair is beyond my comfort level, based on the description. I sort of pick and choose my repair jobs, and I think this one'll wend its way to my local indie. Thanks and I'll let you know the outcome....
__________________
Der Panzermann und Fraulein Fahrvergnuegen

1991 420SEL 201K "The Big Blue One"
1985 300DT 205K chassis/285K engine nee California emissions "Goldbug"
1983 300TDT 255K "The Womble"
1983 300 DT 214K "Sea Sprite"-Rear-ended a truck
1983 300SD 285K "The Donor" Gave his life so that others can live
1980 500SL Euro 105K "Der Panzer"
Reply With Quote
  #7  
Old 05-20-2006, 06:33 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,085
Thumbs up

Honestly it's not as bad as it sounds. It's like swapping servos on a 200-4R or a 700-R4/60E GM unit. I can do them in about 30min or so depending on my beer level.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page