Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-30-2007, 12:23 AM
siral3x's Avatar
Registered User
 
Join Date: Sep 2007
Posts: 124
Cool New MB 300D T owner, need lots of imput please

I just bought a 1985 300 D(Turbo) MB with 185k miles. The car is a North Carolina rust free car.( I do live in MI, till I go to APP. State next year).
I'm trully impresed with this car. After sitting for years and years in a garage, and after one year of not being driven or fired up, the old MB started in just 4 sec crank. WOW!
First impresion with the car:
-Car blows some smoke, and has a rough idle;
-After 10 min the car quits smoking and the rough idlle goes away;
-Car seems to run perfect on the road once it warms uP?
-tried to restart car 2h latter..no rough idle drives fine;
-tried to restart car next morning...Rough idle(it misses?) for 10 min and smoke..till warms up;
-tranny seems to stay to long in 1?? shifts kinda hard in 2nd??

I never owned a MB before, but I did own a 2004 FORD FUSION 1.4 TDCI(Turbo Diesel COmmon Rail Injected).

I invested in MANN oil/fuel/PS filters, but I'm not sure what kind of motor oil would be decent priced and good in the same time(winter in MI goes to 20-30dg or lower). Any sugg?
My friend who is a diesel mechanic told me that most likely the injectors need to be rebuilt bc the fuel doesn't get atomized? like it should at cold startup?? I don't know much about diesels, but it makes sence since it only does sputter at startup and not when the engine is warmmed up.
Any comments???
I'm planning on changing the tranny fluid soon also, and other tune up should I do before winter???

thx a lot
Alex
__________________
DOMAIN NAMES FOR SALE:
www.diesel911.com
www.dieselbenz.com
www.dieseldoctor.biz
Please PM me with offers.
Reply With Quote
  #2  
Old 09-30-2007, 01:03 AM
winmutt's Avatar
85 300D 4spd+tow+h4
 
Join Date: Apr 2006
Location: Atl Gawga
Posts: 9,321
Quote:
Originally Posted by siral3x View Post
I invested in MANN oil/fuel/PS filters, but I'm not sure what kind of motor oil would be decent priced and good in the same time(winter in MI goes to 20-30dg or lower). Any sugg?
My friend who is a diesel mechanic told me that most likely the injectors need to be rebuilt bc the fuel doesn't get atomized? like it should at cold startup?? I don't know much about diesels, but it makes sence since it only does sputter at startup and not when the engine is warmmed up.
Any comments???
I'm planning on changing the tranny fluid soon also, and other tune up should I do before winter???

thx a lot
Alex
Pull the injectors have them poptested and rebuilt if needed. Inspect your prechambers. Get an FSM from MBUSA for $20. 85 is the only year a 2.88 diff was installed. Great for highway miles, not bad around town either. There are a few other 85 only goodies in this model. You may want to take a look at your EGR, you may find a quarter there!
__________________
http://superturbodiesel.com/images/sig.04.10.jpg
1987 300D Sturmmachine
1991 300D Nearly Perfect
1994 E320 Cabriolet
1995 E320 Touring
2001 Eurovan FOR SALE
1985 300D car, sold and missed.
OBK #42
Reply With Quote
  #3  
Old 09-30-2007, 01:39 AM
Registered User
 
Join Date: Aug 2002
Location: NE Okla
Posts: 1,104
Could well be that you have at least one glow plug that is not functioning. This would very definately give you the cold start roughness that you are experiencing. They can be tested, see search function above for looking up threads that pertain to this issue.
__________________
1961 190Db retired
1968 220D/8 325,000
1983 300D 164,150
Reply With Quote
  #4  
Old 09-30-2007, 01:51 AM
Motorhead's Avatar
Registered User
 
Join Date: Dec 2002
Location: Ca.
Posts: 971
Quote:
Originally Posted by Lycoming-8 View Post
Could well be that you have at least one glow plug that is not functioning. This would very definately give you the cold start roughness that you are experiencing. They can be tested, see search function above for looking up threads that pertain to this issue.
Ditto.... Also have the valves adjusted. The intake valves tend to tighten up.
__________________
My Truck.. 2007 DODGE, 5.9 Cummins, 6spd stick, 4X4. My car..1977 240D, OTHER WHEELS...1955 VW Oval window bug, European Delivery (Holland) with a 1700cc, 2 barrel, Porsche drum brakes. 1939 WILLYS Pick-up. 1967 Triumph 200cc Tiger Cub. 1976 Honda 550F 4cyl Motor Cycle.
Reply With Quote
  #5  
Old 09-30-2007, 02:17 AM
winmutt's Avatar
85 300D 4spd+tow+h4
 
Join Date: Apr 2006
Location: Atl Gawga
Posts: 9,321
glowplugs would not lead to 10 minutes of roughness, improper injection will. Did the glowplug light comeon properly?
__________________
http://superturbodiesel.com/images/sig.04.10.jpg
1987 300D Sturmmachine
1991 300D Nearly Perfect
1994 E320 Cabriolet
1995 E320 Touring
2001 Eurovan FOR SALE
1985 300D car, sold and missed.
OBK #42
Reply With Quote
  #6  
Old 09-30-2007, 05:58 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
All of the above, GP's first.
__________________
83 SD

84 CD
Reply With Quote
  #7  
Old 09-30-2007, 11:07 AM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by winmutt View Post
glowplugs would not lead to 10 minutes of roughness, improper injection will. Did the glowplug light comeon properly?

I politely disagree. The symptoms sound like classic glowplug failure. Runs rough at first. Runs fine when hot. Starts and runs smooth after hot.
It would certainly be the first place to recommend a new owner to check, before we start guiding him to pulling injectors and pop-testing.
Do the easy and more common stuff first.
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #8  
Old 09-30-2007, 11:13 AM
siral3x's Avatar
Registered User
 
Join Date: Sep 2007
Posts: 124
Nope, the glow plug light didn't turn on at all. I was kinda worried bc I don't know when the glow plugs kick in??How can I tell when they do? My uncle changed the instrunment cluster and said that not all the lights work. I got the old one also so I was thinking of swapping bulbs. Now if the light doesn't kick on does that mean that a glow plug is bad??
My uncle aslo said he swapped 2 glow plugs some time ago, and he still had 3 more to install. I'm skeptical about the Autolite glow plugs...anybody using them????
I paid $900 on this car and I'm planing to keep it until I get out of college.
__________________
DOMAIN NAMES FOR SALE:
www.diesel911.com
www.dieselbenz.com
www.dieseldoctor.biz
Please PM me with offers.
Reply With Quote
  #9  
Old 09-30-2007, 12:00 PM
Palangi's Avatar
L' Résistance
 
Join Date: Dec 2000
Location: Republique de Banana
Posts: 3,496
Go here for glow plug troubleshooting procedure:

http://www.dieselgiant.com/glowplugrepair.htm

Autolite glow plugs do not have a good reputation on Mercedes cars. They just don't last very long at all. Use Bosch or Beru.
__________________
Palangi

2004 C240 Wagon 203.261 Baby Benz
2008 ML320 CDI Highway Cruiser
2006 Toyota Prius, Saving the Planet @ 48 mpg
2000 F-150, Destroying the Planet @ 20 mpg



TRUMP .......... WHITEHOUSE
HILLARY .........JAILHOUSE
BERNIE .......... NUTHOUSE
0BAMA .......... OUTHOUSE
Reply With Quote
  #10  
Old 09-30-2007, 12:13 PM
siral3x's Avatar
Registered User
 
Join Date: Sep 2007
Posts: 124
ok, i'm just gonna put new glow plugs and see if that would make a diff.
How much torque do u need to apply when you put new ones in??
How do u get out the air in the injector lines??
thx!
__________________
DOMAIN NAMES FOR SALE:
www.diesel911.com
www.dieselbenz.com
www.dieseldoctor.biz
Please PM me with offers.
Reply With Quote
  #11  
Old 09-30-2007, 03:39 PM
winmutt's Avatar
85 300D 4spd+tow+h4
 
Join Date: Apr 2006
Location: Atl Gawga
Posts: 9,321
Quote:
Originally Posted by JimmyL View Post
I politely disagree. The symptoms sound like classic glowplug failure. Runs rough at first. Runs fine when hot. Starts and runs smooth after hot.
It would certainly be the first place to recommend a new owner to check, before we start guiding him to pulling injectors and pop-testing.
Do the easy and more common stuff first.
If hed mentioned the GP light didnt come on ...
__________________
http://superturbodiesel.com/images/sig.04.10.jpg
1987 300D Sturmmachine
1991 300D Nearly Perfect
1994 E320 Cabriolet
1995 E320 Touring
2001 Eurovan FOR SALE
1985 300D car, sold and missed.
OBK #42
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page