Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-24-2008, 02:00 AM
Registered User
 
Join Date: May 2005
Posts: 39
No Power Steering

Im having problems with the power steering. This has been going on for a month , i kept adding power steering fluid and now the power steering does not work at all i even tried adding fluid and the fluid just stays at the top, what could it be? Is it possible the power steering pump failed. Its got about 500,000 miles, I can turn the wheel still but its very very very hard. The belt seems fine tho.
Reply With Quote
  #2  
Old 07-24-2008, 09:45 AM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 26,243
"i kept adding power steering fluid and now the power steering does not work at all"

...
this implies you were running out of fluid often, and when it made noise you topped it off yes?
the pumps are great, but they are not designed to ever run low. odds are good your pump is dead. they are not too hard to change, and most parts yards have a few MB's in them... go get another one.
it's possible that the filter is clogged, you could pull it out and see if it functions...
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #3  
Old 07-24-2008, 11:53 AM
Registered User
 
Join Date: May 2005
Posts: 39
thanks im guessing the same ... this car has started to fail on everything its reaching 500,000 miles ... nothing works .. no power windows no power door locks rust all over ... seats switch are messed up harness is half melted .. problems everywhere cluster just took a crap on me too ... i found a nice 87' black on black for a good price no rust .... im goin to try to get it and part the 1 i have ... my father owned it for 22 years .. and it will strike my heart when i get rid of this .. but the car has got cancer and everything is falling apart .. i might be doing a part out ... thanks again for the help
Reply With Quote
  #4  
Old 08-29-2008, 07:17 AM
Registered User
 
Join Date: May 2005
Posts: 39
kk im back .. umm im confused there is a power steering pump and then hoses leading to something else... what is that?? im confused ... any body have instructions on how to change the pump?
Reply With Quote
  #5  
Old 08-29-2008, 12:14 PM
bgkast's Avatar
Rollin' on 16s
 
Join Date: Dec 2005
Location: Vancouver WA
Posts: 6,528
Do the hoses lead to the steering box?
__________________
1979 240D- 316K miles - VGT Turbo, Intercooler, Stick Shift, Many Other Mods - Daily Driver

1982 300SD - 232K miles - Wife's Daily Driver

1986 560SL - Wife's red speed machine
Reply With Quote
  #6  
Old 08-29-2008, 12:26 PM
babymog's Avatar
Loose Cannon - No Balls
 
Join Date: Jan 2006
Location: Northeast Indiana
Posts: 10,767
If it was sold new in the US, should only go to the steering box and to the cooling loop in front of the radiator.

If non-US, it could have the dual PS and SLS pump which will have a separate hydraulic tank and four lines to the pump.

If it is not boosting, probably worn out, likely a relief valve hanging open?
__________________

Gone to the dark side

- Jeff
Reply With Quote
  #7  
Old 08-29-2008, 09:35 PM
Jeremy5848's Avatar
Registered Biodiesel User
 
Join Date: Mar 2006
Location: Sonoma Wine Country
Posts: 8,394
Anyone know if the 300E uses the same pump? There tend to be a good number of them in junkyards -- they don't get kept like the diesels do.
__________________

"Buster" in the '95

Our all-biodiesel family
1995 E300D (W124) . .239,000 miles My car
1996 E300D (W210) . .313,000 miles Wife's car
Santa Rosa population 170,685 (2012)
Total. . . . . . . . . . . . 722,685
"Oh lord won't you buy me a Mercedes Benz."
-- Janis Joplin, October 1, 1970
Reply With Quote
  #8  
Old 08-29-2008, 10:12 PM
Registered User
 
Join Date: Feb 2008
Location: DFW area (north side)
Posts: 1,288
Some possibility that you might have an air lock and need to bleed the system. Do a search for the procedure or look in the DIY section of the forum. I'd fix the leaks and bleed before I started looking for another pump.
__________________
Charles
1983 300D, bought new, 215k+ miles, donated to Purple Hearts veterans charity but I have parts for sale: http://www.peachparts.com/shopforum/mercedes-benz-cars-sale/296386-fs-1-owner-83-mb-300d-turbo-rebuild-parts.html
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page