Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2009, 03:28 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Refurbing the Dash Light Rheostat (Caution: For The Purists Out There)

My dash and console lights were not working on the '83 240D. After doing some searching I realized that it had to be the rheostat located on the back of the instrument panel. If you own an older MB and none of your dash or console light are working, there's a good chance your rheostat is corroded. What is a rheostat you say? A rheostat is simply a device that allows you to control the resistance in a circuit. In this case, it allows you to control the brightness of the dash lights. Unfortunately, the internal contacts tend to corrode over time and eventually enough corrosion will halt the current flow through the rheostat with the end result being no more lights.

The most common "fix" for a bum rheostat is to simply solder a jumper wire across the two metal strips on the back of the rheostat. This effectively bypasses the internal components, which is good because it gets your lights back. However, in doing so you sacrifice the ability to dim your lights if you want to. The argument for bypassing the rheostat is that, even on "high", the dash lights in these older MB cars are not all that bright. After fixing mine, I agree, but nevertheless, I still wanted to open up the rheostat to see what it looked like inside and, once I did, I realized it wouldn't be a hard fix - so I cleaned up the contacts, put it back together and now it works great. What follows is a DIY on refurbing you dash light rheostat.
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman

Last edited by tankowner; 08-29-2009 at 12:47 PM.
Reply With Quote
  #2  
Old 08-28-2009, 03:50 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 1: Remove the instrument panel.

Probably the easiest way to remove the panel is to reach up from behind and push it out. You can make the little tools to pull it out, but it really is quite easy to remove the panel below the steering column (3 screws) and reach up there to push it out. Just keep in mind there are some things you will need to disconnect to get it out. Unscrew the speedo cable. Unbolt the oil pressure line (in my '83 240D the nut is 10 mm). Finally, undo the electrical connections. Be sure to keep track of where everything goes.

Note: No starting of the car while the oil pressure line is disconnected . . . ask me how I know that . . ..

See the little white box with the two metal strips on it (near the bottom of the panel) - that's the rheostat.

__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman

Last edited by tankowner; 08-28-2009 at 09:10 AM.
Reply With Quote
  #3  
Old 08-28-2009, 03:55 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 2: Remove the rheostat from the panel.

To remove the rheostat from the panel, simply unscrew the one screw that holds it on. It will not come right off, it is still on the two pin electrical contacts. You will need to pull it straight out from the panel - no twisting or you might break off a pin.



I used a small flat-head screw driver to pry it just a little to get is started. Go slow, it will come off pretty easily.




Here are the two pins that the rheostat connects to, be careful not to break them.

__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #4  
Old 08-28-2009, 04:18 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 3: Disassemble the rheostat - but watch out for the little springs.

To get into the business parts of the rheostat you will need to remove the metal clips that holds the the dial and slider components against the coil and coil housing. Just pull outward on the clips and it will come off easily. You might deform the metal clips a little, but you can bend them back in a little to make sure they do their job once reassembled.

Here is what the rheostat looks like on the inside. I am holding on to the dial part that turns when you spin the little knob on the front of the dash panel to adjust the light brightness (same knob that resets the tripometer, by the way).

CAUTION: Do not attempt to take the rheostat apart in your car or in your driveway or anywhere but over a table top where you can watch for the two little springs that are going to fall out. Once you get the dash panel out of your car, I would take it to where you plan to do the work before you even remove the rheostat from the panel. It is not a pain to deal with these springs, but if you lose just one of these its all over for your rheostat (although you can always do the jumper wire trick).

Okay, it's not going to look like this when you pull it apart, the sprigs and slider will fall out. This is just a staged shot to show you how the slider sits on the dial mechanism (the two little springs are currently underneath it - their job is to hold the slider against the coil when everything is assembled. You can see the coil in the housing to the right.





Another staged shot to show you how the springs sit in the dial mechanism. The slider is removed and laying in the background. The metal braket that holds it all together doesn't actually go there - i was just using it to hold the dial upright so I could take the picture.




Here are all the pieces. Do not attempt to remove the coil from the housing as it is attached on one end. Break the coil off and, again, you will be resorting to the jumper method. It's not fragile, just don't pull it out.




The coil will pull up from the side that it is not attached. Many others have noted the white powder material that seems to build up inside (I cleaned it out of the coil area - see it below the housing.) Not entirely sure what that is. May be that the housing is made out of bakelite and it degrades a little over time. Regardless, if your rheostat isn't working you probably have some of the white stuff along with corroded components.



Although the finger projection of the slider runs along the coil (which is fairly clean), there are other contact points of the slider that make contact with the little disc in the center. See how corroded it is? We need to clean that . . . and the slider, too.

__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman

Last edited by tankowner; 08-29-2009 at 12:50 PM.
Reply With Quote
  #5  
Old 08-28-2009, 04:25 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 4: Clean off the corrosion.

I started out with some battery cleaner to help loosen things up a little. Let it sit for a couple of minutes.




Then I took a small screw driver and scraped off the corrosive coating. See how it wants to be shiny and new again?



Some other materials I used, probably not all required, but I wanted to do it right the first time. I started with the battery cleaner. Then I scraped off as much corrosive coating as I could with the little screw driver. Then I used some fine grit paper to take off even more corrosive coating. Afterwords I sprayed it down with electrical contact cleaner and let it dry. You'll see what I used the di-electric grease for in a minute.



Now we're looking good . . .

__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #6  
Old 08-28-2009, 04:43 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 5: Reassemble the rheostat.

Now it's time to put the rheostat back together. Put a little bit of di-electric grease on one end of each spring and place them back in their holes. The grease will keep them in place as you reassemble.




From there you just need to hold the slider onto the spring and place it back into the housing. The metal clip is what holds the dial/spring/slider assembly onto the coil housing, so you will need to hold it in place as you slide the metal clip back on.

Once it is back together, you should try rotating the dial a few times to see if the slider runs good along the coil. When I tried it I found that the slider was now pushing the coil out of its track - see below (it shouldn't be sticking out like that).




So, how do you fix that? More di-electric grease, of course. I lifted up the coil, placed a few globs of grease in the track and then pressed the coil into the grease. Worked like a charm, the grease held the coil in the track and the slider moved smoothly across the surface of the coil. Note that you can rub a little dielectic grease on some of the metal components to keep them from corroding, but avoid getting it on the contact surfaces.

That's it! As they say, assembly is the reverse, right? Mount the rheostat back on the panel and reconnect the panel.
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman

Last edited by tankowner; 08-28-2009 at 09:12 AM.
Reply With Quote
  #7  
Old 08-28-2009, 04:44 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Step 5: Enjoy those dash lights and your functioning rheostat!

__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #8  
Old 08-28-2009, 07:46 AM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
Great write up with excellent pic's. You are correct in that the surgery should not be attempted in a stone driveway, with the possiblity (near 100%) of the springs taking flight.

One little thing from a historical point, you might wish to amend, On my '83 300D there is a oil pressure sensing line, not a brake pressure.
Otherwise you are right on.

Great Job.

BTW is a clock repair in your future ? Or just happened to be midnight.
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
  #9  
Old 08-28-2009, 08:34 AM
fruitcakesa's Avatar
Registered User
 
Join Date: Jun 2008
Location: Vermont
Posts: 1,115
Fine pictorial and explanation. Thanks
__________________
1981 240D 132k 4 spd manual
Finally got the clutch bled!
1982 240D 228+k. 4 spd auto. SOLD
2002 VW Jetta TDI auto, 207k, Koni SRT, Frostheater, DG Alum Skidplate, ventectomy, Fuel pickup mod. Wife's car
1995 Dodge 2500 4x4 Cummins diesel, 5 speed 182k, 3rd gen trackbar, PSD steering shaft. Everything else that needs transport
Reply With Quote
  #10  
Old 08-28-2009, 09:07 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Quote:
Originally Posted by cessna5354 View Post
One little thing from a historical point, you might wish to amend, On my '83 300D there is a oil pressure sensing line, not a brake pressure.

Otherwise you are right on.

BTW is a clock repair in your future ? Or just happened to be midnight.
LOL - you know, it just didn't sound right when I typed it, but it was late. You are, of course, correct. I will make that correction.

Also, I should point out that it is not a good idea to do trouble-shooting on your vacuum system while that oil pressure line is disconnected. Meaning, DO NOT, start the vehicle with the line detached. Ask me how I know!!! It's not like I didn't know oil would start spraying out of that line - my mind just really wanted to test the vac line at the ignition (since mine isn't curently shutting off with the key). Lucky for me the mess was minimal and since I had hooked up the Mity-Vac to the vac line I was able to shut it down fast.

Clock repair??? How did you know my clock wasn't working? Unfortunately it wasn't midnight . . . more like 3 AM . . . dumb me. That looks a tad more difficult, but . . . who knows.

Thanks for catching my mistake.
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman

Last edited by tankowner; 08-28-2009 at 10:21 AM.
Reply With Quote
  #11  
Old 08-28-2009, 10:20 AM
Outofworkjoe's Avatar
Navy Vet,A7,F18,F4,KA3B
 
Join Date: Mar 2009
Location: Philly
Posts: 87
Hey I got lucky with my dash lights,just turned the knob about fifty times,on and off, work now but very dim. 83 300d
Reply With Quote
  #12  
Old 08-28-2009, 10:25 AM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Quote:
Originally Posted by Outofworkjoe View Post
Hey I got lucky with my dash lights,just turned the knob about fifty times,on and off, work now but very dim. 83 300d

Yeah, others have reported success by doing exactly what you did. I tried that . . . but to no avail. I think the reason these get this way in the first place is because they don't get much use at all. I mean, honestly, how often do you adjust the brightness of the dash lights . . . especially when they are already dim on high. Unfotunately I just wasn't getting any response from mine . . . and after cleaning it I can see why.
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #13  
Old 08-28-2009, 12:11 PM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 22,708
...
now wire in some LCD's and get good brightness on the dash!@
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #14  
Old 08-28-2009, 02:40 PM
tankowner's Avatar
You talkin’ to me?
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 907
Quote:
Originally Posted by vstech View Post
...
now wire in some LCD's and get good brightness on the dash!@
LEDs?
__________________
'95 E300D ("Tank") - 231,000 miles
'79 240D ("Biscuit") - 197,250 miles (Sold)
'83 240D ("Ding-Ding") - 217,000 miles (Death by deer)
______________________________________

"Back off, man. I’m a scientist” ~ Peter Venkman
Reply With Quote
  #15  
Old 08-28-2009, 03:34 PM
Phil's Avatar
Registered User
 
Join Date: Dec 2004
Location: Sonoma County, California
Posts: 1,017
That is what I love about these cars. It is possable to fix most everything instead of replacing.
__________________
1983 300SD
200000miles
Reply With Quote
Old 08-28-2009, 03:34 PM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page