Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-09-2009, 05:05 PM
Registered User
 
Join Date: Jul 2008
Location: DFW area (NE Tarrant Cnty)
Posts: 29
Replaced monovalve-now my AC has hot air mixed in

I have a 1986 300SDL. I replaced a torn monovalve last night and now I have hot air mixing with the cold air. The only place it feels a little bit cool is in the left/right lower vents (not the one where part of the vent in a "fixed-vent" to blow on the windows).

I know there are hundreds of threads about A/C and heat but I was hoping someone might have quik fix or something to check.

This was bad timing as it's 95 degrees here in Dallas today. I had no heat last winter but it really only bothered me on one road trip. I thought I would go ahead and replace it but if I don't figure something else out pretty quick I will put the torn one back in until winter time.
__________________
1986 300SDL - 71K miles - Champagne metallic w/Brazil brown interior
1987 300SDL of the same colors--239K miles...soon to be sold to my cousin...
Reply With Quote
  #2  
Old 09-09-2009, 05:57 PM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 4,872
Was it a new or used monovalve?
__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 210K miles

03 VW Golf TDI 5 speed 372K Miles

RIP--Lost in fire...82 300D 322K was My Daily Driver-On the search for a w126 now...

90 Dodge D250 5.9 Cummins/5 speed. 350K
Reply With Quote
  #3  
Old 09-09-2009, 06:35 PM
Registered User
 
Join Date: Jul 2008
Location: DFW area (NE Tarrant Cnty)
Posts: 29
It was a new one. It was free to me since someone gave it to me. I can't remember if there was a brand name on the box. It seems llike it was blue and white. It was not Bosch. There was German writing on it though.

You think it may be bad?
__________________
1986 300SDL - 71K miles - Champagne metallic w/Brazil brown interior
1987 300SDL of the same colors--239K miles...soon to be sold to my cousin...
Reply With Quote
  #4  
Old 09-09-2009, 07:41 PM
Registered User
 
Join Date: Feb 2008
Location: DFW area (north side)
Posts: 1,288
I bought a set of 3 monovalve repair kits on ebay last year. None of them worked. I did save the rubber pieces to put on a Bosch unit that had a torn diaphram.

The test I used was: Use the top solenoid coil and insert the kit into it. Apply 12V and the valve should extend and stay extended (close). These stuttered in and out.
__________________
Charles
1983 300D, bought new, 215k+ miles, donated to Purple Hearts veterans charity but I have parts for sale: http://www.peachparts.com/shopforum/mercedes-benz-cars-sale/296386-fs-1-owner-83-mb-300d-turbo-rebuild-parts.html
Reply With Quote
  #5  
Old 09-09-2009, 11:38 PM
Registered User
 
Join Date: Jul 2008
Location: DFW area (NE Tarrant Cnty)
Posts: 29
Good idea... I'll have a look at the one I put in and maybe trade out the rubber diaphram to the original Bosch.

BTW, this one I put in says VENTIL EINSATZ (which is german for "valve insert"?) in a blue and white box. So it's apparently a noname brand.
__________________
1986 300SDL - 71K miles - Champagne metallic w/Brazil brown interior
1987 300SDL of the same colors--239K miles...soon to be sold to my cousin...
Reply With Quote
  #6  
Old 09-10-2009, 12:10 AM
Craig
Guest
 
Posts: n/a
Also, check the electrical connection on the monovalve. Last time mine started acting up, it turned out to be slightly loose connections. A little adjustment and some conductive "grease" solved the problem.
Reply With Quote
  #7  
Old 09-10-2009, 12:38 AM
Registered User
 
Join Date: Jul 2009
Posts: 29
if you want quick fix you can always put shutoff valves on your heater hosess and shut them off thru summer,and open them thru winter
Reply With Quote
  #8  
Old 09-10-2009, 02:05 AM
Registered User
 
Join Date: Jul 2008
Location: DFW area (NE Tarrant Cnty)
Posts: 29
Thanks guys for the additional input. I'll check into those things too. Looking at the old monovalve insert again tonight, it doesn't look like it would be a piece of cake (for my limited skills anyway) to take apart and put back together with an intact diaphram. I might as well take the old one apart anyway.

At least I know I will have cold AC again here in the next few days when I get time. I have another car I can drive in the meantime.

BTW, I bought another one of these things last week. (I must be catching the disease). It's a 1987 300SDL, same color interior and exterior but with about 237K miles. It has a few issues but for what I paid (dirt cheap), it's fine if it turns out to be a parts car. But I will have to start a new post about that car when I get the time.
__________________
1986 300SDL - 71K miles - Champagne metallic w/Brazil brown interior
1987 300SDL of the same colors--239K miles...soon to be sold to my cousin...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page