Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2010, 02:47 PM
Registered User
 
Join Date: Feb 2007
Posts: 6
Glow Plug Diagnostic Procedure needed 96 E300D

Replaced glow plugs within the last 12 months have worked great. Glow plug lamp no longer illuminates when ignition is turned to pre-glow position. Some times after engine has been running glow plug lamp will illuminate and then go out. Really want to sort through this. I've inspected the terminal connection at each GP and all seems in order. I'm a bit green but willing and in need of the counsel of glow plug wisdom.
Reply With Quote
  #2  
Old 01-11-2010, 03:05 PM
Olivier's Avatar
Registered User
 
Join Date: Jan 2009
Location: Edinburgh
Posts: 569
Would that be a burned glow?
I have massive problems with NGK that will not stand the heat on a E300 turbo.
They lastet more or less 6 month.
__________________
E300TD year 2000. RUSTY SOLD
cost a fortune to maintain on the road
but run well on WVO
Second Merc died due to corrosion ( NOT rust) How can mercedes get away with that for so long?
Third lasted a month then went away...
Fourth now... Corroded too...
Reply With Quote
  #3  
Old 01-11-2010, 05:06 PM
Registered User
 
Join Date: Feb 2007
Posts: 6
burned GP

Your absolutely correct. bad #5. Now to patiently r&r.
Reply With Quote
  #4  
Old 01-11-2010, 07:24 PM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
NGK "Wrong, Wrong" "Alla De Time"

Oliver,

Beru or Bosch, only.
__________________
'84 300SD sold
124.128
Reply With Quote
  #5  
Old 01-11-2010, 07:33 PM
Olivier's Avatar
Registered User
 
Join Date: Jan 2009
Location: Edinburgh
Posts: 569
Tell me about it...
First time I didn't know, then happilly got 6 ngk. They failled quickly. As because of them, I changed the injectors thinking it was due to bad athomisation. Got 5 beru as I had about 3 ngk good, big mistake, on the worse time possible on sunday when all the shop were close one failed (NGK) and the bother was that I needed to catch a boat the next day. The only glows I could get early on monday was, guess which brand... NGK... I took all 6 new as I didn't know how many failed. 3 month later I had a failure again... one by one...
No more NGK....
Pfff that was a long story
__________________
E300TD year 2000. RUSTY SOLD
cost a fortune to maintain on the road
but run well on WVO
Second Merc died due to corrosion ( NOT rust) How can mercedes get away with that for so long?
Third lasted a month then went away...
Fourth now... Corroded too...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page