Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-18-2011, 11:59 PM
chetwesley's Avatar
Incompetent Loser
 
Join Date: Jan 2007
Posts: 745
wipers blowing fuse immediately

The other day I disconnected my battery with car running and wipers started moving on their own (powered by alternator which may have been putting out too high of a voltage at the time).

Now known that this maybe wasn't a great idea, so let's move on to how to fix the wipers as rainy season has just come upon us and I drive this car a lot.

I noticed wipers weren't working, so I checked fuses - it was blown. I replaced it, turned on the wipers, and it blew immediately again -- wipers didn't even move before it blew.

Any ideas as to what could be the potential causes of the fuse blowing, as in, what could have been burned out/shorted out when too much electricity had it's way with the wipers and other items on the wiper fuse ("optical horn" - don't know what that is).

If I remember, the wiper motor is a pain in the ass to get at... any ideas as to first items to look at? Is there a wiper relay of some sort?
__________________
1979 240D w/4 Speed Manual, Light Blue Estimated 225-275K Miles - "Lil' Chugs"
Sold but fondly remembered: 1981 300TD Turbo Tan 235K miles, 1983 300SD Astral Silver 224K miles

Reply With Quote
  #2  
Old 10-19-2011, 04:48 PM
Registered User
 
Join Date: Nov 2004
Location: Nova Scotia, Canada.
Posts: 6,510
Thats what I neglected to post the other day. The relay may be bad from the overvoltage. I do not know the exact location of it.

The other thought was if the wipers started to operate without you turning them on during the higher voltage problem the wiper motor and contacts inside it are probably fine. Some member may be able to quote you where that relay is.
Reply With Quote
  #3  
Old 10-20-2011, 03:15 AM
chetwesley's Avatar
Incompetent Loser
 
Join Date: Jan 2007
Posts: 745
thanks. also have a service manual somewhere if i can dig it up on my old computer. it probably has the wiper electric diagrammed.

if anyone has any ideas it will help regardless.
__________________
1979 240D w/4 Speed Manual, Light Blue Estimated 225-275K Miles - "Lil' Chugs"
Sold but fondly remembered: 1981 300TD Turbo Tan 235K miles, 1983 300SD Astral Silver 224K miles

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page