Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-29-2013, 05:11 PM
Registered User
 
Join Date: Jul 2008
Location: Baltimore, MD
Posts: 262
300d wipers not work electrical smell and blow fuse

I have 1984 300d with 335k on it.
I was driving in the rain the other day with my wipers on and I started to smell an electrical/plastic smell in the car. About 3-5 seconds later, the wipers stopped working and are now stuck in the up position.

I checked the fuse and it's blown. When I replaced it, the new fuse blew immediately.

Any ideas where I should start to look?

Any info would be greatly appreciated.

Thanks.

Pete
Reply With Quote
  #2  
Old 11-29-2013, 06:14 PM
TnBob's Avatar
Registered User
 
Join Date: Dec 2009
Location: Shelbyville, Tn
Posts: 1,907
I know you dont want to hear it but sounds like your wiper motor blew.
__________________
1985 300D 198K sold
1982 300D 202K
1989 300E 125K
1992 940T

"If you dont have time to do it safely, you dont have time to do it"

"The democracy will cease to exist when you take away from those who are willing to work and give to those who would not."
Reply With Quote
  #3  
Old 12-01-2013, 09:09 PM
Registered User
 
Join Date: Jul 2008
Location: Baltimore, MD
Posts: 262
You were right.
I pulled the wiper motor and replaced it.
All is good.

One tip for others replacing the wiper motor.

The 4 square clips that are holding the grill and the 4 round rivets that are holding the metal plate between the grills have a square and round piece of plastic in the middle.
Push them into the body with a punch or little screw driver to remove the grills and the metal piece. Be careful removing the round plastic rivets. They can easily break.


Thanks for the reply.

pete
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page