Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #31  
Old 12-12-2016, 04:15 AM
Stretch's Avatar
Gettin' outa chokey
 
Join Date: Sep 2009
Location: Between a rock and a hard place (Back in Holland at the moment)
Posts: 13,986
Quote:
Originally Posted by caswda View Post
Did that.. No change just a big mess... I'm stumped! I can make it bog down if I lay into it that's when it really starts to get bad I would still go for fuel supply but I've had that auxiliary tank hooked up and there was definitely no air getting to it then and I had the same issues. I just don't know these cars are crazy....
Well if you're sure it isn't fuel then I'd be looking at air.

Has it got a turbo?
__________________
1992 W201 190E 1.8 171,000 km - Daily driver
1981 W123 300D ~ 100,000 miles / 160,000 km - project car stripped to the bone
1965 Land Rover Series 2a Station Wagon CIS recovery therapy!

Don't leave that there - I'll take it to bits!
Reply With Quote
  #32  
Old 12-14-2016, 07:16 AM
Registered User
 
Join Date: Dec 2016
Location: Fernandina Beach, FL
Posts: 25
Reply

Quote:
Originally Posted by Stretch View Post
Well if you're sure it isn't fuel then I'd be looking at air.

Has it got a turbo?
Yes it is indeed a turbo, I also noticed that the corrugated exhaust tube has a crack in it. Do you have any idea where I could get one and what would be the significance of it being cracked would have on engine operation.!
Reply With Quote
  #33  
Old 12-14-2016, 07:39 AM
t walgamuth's Avatar
dieselarchitect
 
Join Date: Apr 2005
Location: Lafayette Indiana
Posts: 32,121
I'm sure you can get one here. No effect on running though.
__________________
[SIGPIC] Diesel loving autocrossing grandpa Architect. 08 Dodge 3/4 ton with Cummins& six speed; I have had about 35 benzes. I am finishing a 39 Studebaker Coupe Express pickup in which I have had installed a 617 turbo and a five speed manual....I also have a 427 Cobra replica with an aluminum chassis.
Reply With Quote
  #34  
Old 12-14-2016, 09:25 AM
Registered User
 
Join Date: Aug 2012
Location: Northwest Indiana
Posts: 4,935
In post #13 you mentioned you ordered a new primer pump, I did not see a follow up after that was installed. The only reason i bring that up is when I replaced them that was a huge improvement in starting ease and also on the power side, but each time on different vehicles I was going from the white cap to the Bosch.
Reply With Quote
  #35  
Old 12-19-2016, 02:04 AM
Registered User
 
Join Date: Dec 2016
Location: Fernandina Beach, FL
Posts: 25
Reply

Quote:
Originally Posted by sloride View Post
In post #13 you mentioned you ordered a new primer pump, I did not see a follow up after that was installed. The only reason i bring that up is when I replaced them that was a huge improvement in starting ease and also on the power side, but each time on different vehicles I was going from the white cap to the Bosch.
Hi sloride.
Sorry, had to walk away from this mess for a while..
I did replace the primer pump but it did not correct the shutdown problem. I have replaced some vacuum lines that wer missing, One was missing from the EGR valve and the other two where missing from the 2 connections sitting on top of the thermostat area. I assumed that they all went into that control box sitting on top of the valve cover, without a vacuum schematic, I have no idea. With those replaced I have gotten it to the point of not shutting down but it still is definitely not running at full potential. I need to get a hold of a vacuum pump and clear up all of these vacuum issues before moving forward.
Reply With Quote
  #36  
Old 01-06-2017, 09:25 AM
Registered User
 
Join Date: Dec 2016
Location: Fernandina Beach, FL
Posts: 25
Why can't I keep This Thing Running! Solved - Temporary Fix

Well, The problem i was having was definitely The Lift Pump. Here is my temporary fix until I can rebuild. Please do yourself a favor and buy a HOLLEY, Not a Mr. Crapsget...
Attached Thumbnails
84 300D Why can't I keep this thing running!?-pump0.jpg   84 300D Why can't I keep this thing running!?-pump1.jpg  
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page