Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-20-2000, 04:05 AM
Registered User
Join Date: Oct 2000
Location: Oakland, CA USA
Posts: 221
I have an '87 560SEL and the lighting for the controls on the right side of the climate control (economy, off, and the fan control-high, auto, low) are dimmer than those on the left. Is there a bulb that I can change, or do I need new switches (for example, the controls for the back seat, where the actual switches are illuminated). Any help would be appreciated.
Reply With Quote
Old 10-20-2000, 07:57 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You will have to remove the control unit and then replace the bulbs. The bulbs are cheap, it is the labor that costs.

Donnie Drummonds
Reply With Quote
Old 10-22-2000, 04:13 AM
Registered User
Join Date: Oct 2000
Location: Oakland, CA USA
Posts: 221
Thanks for the advice
Reply With Quote
Old 10-24-2000, 09:19 PM
Registered User
Join Date: Oct 2000
Location: Oakland, CA USA
Posts: 221
Well, I got the climate control console out of the car, and I can see the dead lamp through a hole in the front of the unit, but I can't figure out how to get to the lamp. There are 4 screws on the bottom of the unit, I have removed them and there is a circuit board beneath the plastic cover. Now I'm stuck, the circuit board seems to be attached to the control buttons, and doesn't want to come out. What am I missing here? any suggestions would be appreciated!
Reply With Quote
Old 10-24-2000, 10:27 PM
Posts: n/a
Use a small piece of thin vac line to push over the bulb and pull out. I used to use those plastic shielding covers for wires used by MB. It covered a single wire. Worked great.

Mercedes-Benz Master Guild - 2 years
Shop Foreman - 20 + years - dealer.
Part owner - MBZ Transmission remanufacture
2000 SL500
1999 ML430
1989 300SE
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
No lights on my W124 Climate Control jjalex Tech Help 11 11-23-2012 04:36 PM
1979 116 climate control fiasco/help DaveMcDonald Tech Help 1 12-11-2004 01:14 AM
"Another" Climate Control question.... rwthomas1 Diesel Discussion 4 12-04-2002 06:13 PM
Climate control unit '88 260E robbysf Tech Help 1 09-16-2002 12:39 PM
Climate control problem-HEAT Johnson Chan Tech Help 2 03-27-2002 05:48 PM

All times are GMT -4. The time now is 04:54 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page