Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-02-2004, 02:49 AM
Registered User
 
Join Date: Aug 2004
Posts: 9
Camber setting on 97 C230K

Hi Guys ...

Yeah ... I may have some problems here .. I bought a second hand C230K, have had it for more then a year and noticed that my front left tyre was wearing unevenly. I took it in for allignment and got a reading of +0deg37' for the camber on the Left front tyre. The spec range is -1deg22' to -0deg42'.

Clearly this is my problem as the tyre has got positive camber when it should have negative camber. The wheel balance guys tell me that the camber is not adjustable on these cars. Is this true and what can I do about this ??

Returning the car is not an option and I need to determine if this is a severe problem and whether it can be fixed. I have noticed a very slight pull to the left which I had never really paid any attention to in the past.

Any comments or suggestions would be most welcome ...

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page