Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-06-2000, 11:51 AM
tex tex is offline
Registered User
Join Date: Nov 2000
Location: reno, nv
Posts: 32
My 1991 2.5 turbo diesel has 140k mi.
Until about 2 months ago, the car
accelerated briskly from 2200 rpm when
the turbo kicked in. In the last 2
months, the car often shows no increase
in power at 2200 rpm, and very low power
until approximately 3700 rpm. The fuel
injectors have not been replaced in the
last 70k mi and are probably original
to the car. In the last 6 months it has idled rough to very rough. Fuel filter
changes and Redline fuel treatment
have helped greatly and the primary
fuel filter now runs clear. Idle is
still somewhat rough at times.
I suspect the injectors are the
problem but would appreciate any
assistance in diagnosing the problem.


Reply With Quote
Old 11-06-2000, 04:36 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Doubt if injectors are causing boost problem. Start with timing chain inspection & injection pump timing check. There are 2 TRANSDUCERS for boost & air flap controls that can also cause boost problems. Several bulletins & modifications to these parts.
Reply With Quote
Old 11-06-2000, 07:48 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
To add to DOC, I have seen where the plastic line that carries boost to the Pressure Sensor will crack or blow off. When this happens the computer will limp.

Have it checked.

Donnie Drummonds
Reply With Quote
Old 11-07-2000, 10:12 PM
Posts: n/a
from the intake there is a hose that goes to a silinoid on the driver side fire wall, that then goes to the injection pump. I replaced mine for 26 dolloars and cleaned the hoses insides, and my problem with boost went away. and on the back of the pump near the oil can is a double bolt that has a spring loaded thing that smooths out idle, rplaced mine and my car runs like new with 240,000 miles on it.
Reply With Quote
Old 11-08-2000, 09:55 AM
tex tex is offline
Registered User
Join Date: Nov 2000
Location: reno, nv
Posts: 32
Thank you all for the info. Chain
inspection and specs are not
covered by the service CD. Are
there specs or is any problem
obvious due to slack in the chain
beyond the tensioner's reach?

I inspected the hose and sensor on
the intake and all appear in good
shape. I did find diesel fuel
(not oil) leaking from the
inspection plate on the bottom of
the fuel injection pump. Could
this be related?

Are there test procedures buried in
the CD regarding the transducers
and solenoid?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300D Crawls at Acceleration Obaid Rehman Diesel Discussion 2 12-04-2002 08:40 PM
'82 300D has no acceleration until a certain point. Help!! Sparky Diesel Discussion 5 07-18-2002 07:33 PM
1991 300D wheel squeak Ben300SD Tech Help 1 08-03-2001 04:27 PM
Unhappy 1985 low mileage 300D Wijiji Tech Help 3 02-07-2001 04:57 PM
1991 420SEL slow driver's window DieselGuy Tech Help 2 04-27-2000 04:40 PM

All times are GMT -4. The time now is 09:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page