Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-15-2000, 07:43 AM
flipSyde
Guest
 
Posts: n/a
on my 1993 500SEL, I recently began losing lights, first on the tach side, and now on the gas gauge side. Needless to say, very cheesy for a car of this caliber...

is there an easy way to fix this? also, would it be possible to switch in a later model digital cluster? I'm not TOO worried about mileage readings as it is close to 170k on the clock anyway. If any one has any suggestions, please let me know.

Chris

------------------
Chris Singh
1983 300D
1993 500SEL brilliant silver w/ AMG monoblock II 19"

http://benz.mp3car.com
http://stormworks.max3d.com
Reply With Quote
  #2  
Old 10-15-2000, 09:28 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Factory replacements are Digital, like the 1994 & later cars. On the Analog inst clusters there are several companies that can FIX the Mother board in the cluster for $350-400. About 1/3 the price for a new cluster. OF course every model has it's own cluster so only one from 1992-1995 500SEL will work in your car!
Reply With Quote
  #3  
Old 10-15-2000, 01:28 PM
flipSyde
Guest
 
Posts: n/a
DOC thanks for the reply. So you are saying that the actual board needs repair just to have illumination in the cluster? for lack of a better term, that kinda sucks.

------------------
Chris Singh
1983 300D
1993 500SEL brilliant silver w/ AMG monoblock II 19"

http://benz.mp3car.com
http://stormworks.max3d.com
Reply With Quote
  #4  
Old 10-15-2000, 02:10 PM
BZP
Guest
 
Posts: n/a
Those illumination bulbs are replaceable. I think that there are 4 or 5 that light up your whole cluster. The illumination for the outside temp. cannot be fixed by these simple means though (new cluster). It is cool that replacement clusters are now all digital.

Bill
Reply With Quote
  #5  
Old 10-15-2000, 03:42 PM
flipSyde
Guest
 
Posts: n/a
Thanks for the tip...any hints on the procedure to replace the bulbs and where to get them? This is really bothering me...

------------------
Chris Singh
1983 300D
1993 500SEL brilliant silver w/ AMG monoblock II 19"

http://benz.mp3car.com
http://stormworks.max3d.com
Reply With Quote
  #6  
Old 10-15-2000, 04:38 PM
BZP
Guest
 
Posts: n/a
You are probably better off bringing it to the dealer. The 140 clusters are as tight as the 129s. The dash hooks required to remove them need to be bent at an additional angle to get a good grip on the housing.It is very easy to break the housing and lens trying to pry it out. Not to say that it cannot be done at home, but it can turn into more money than expected. The bulbs simply twist out of the back of the cluster. I would buy the bulbs from the dealer and replace them all while you're in there.Probably get charged an hours labor. Good Luck.

Bill
Reply With Quote
  #7  
Old 10-15-2000, 10:00 PM
Registered User
 
Join Date: May 1999
Location: Charlotte, NC, USA
Posts: 688
flipSyde,
I also had cluster problems with my '92 140
and had to pull it out to get it repaired. There is an easy way to do this. Pull up the black screen in the corner of the dash and w/s, then remove the two screws holding the top of the left vent in place. Remove the vent and some of the duct extensions behind it. NOW you can put your hand in and push the cluster from the rear and NOT use hooks to pull it out. Hence, no broken cluster. Reinstall in the reverse manner. Check your fuel level and you can drive the car while the cluster is out! Been there, done it!

Tobias MB
400E, C280Sport, 300CE, 190/5.0
92 300SE..sold the junker!
Reply With Quote
  #8  
Old 10-16-2000, 04:02 AM
Registered User
 
Join Date: Jun 2000
Location: Dubai, United Arab Emirates
Posts: 238
.........Perhaps this might be a good time to remind all us budding mechanics of the post on 29th Sept by Senior Member Aaron. Seems he cut a finger badly with broken glass from a brake lite bulb. Let's all be very careful with these bulbs, be they brake lite ones or the fiddly little ones in the instrument cluster !
Reply With Quote
  #9  
Old 10-16-2000, 09:44 AM
flipSyde
Guest
 
Posts: n/a
Guys,

I was away for awhile after I sold my 300E, but this little thread reminds me of what a great site this is. Thanks for the help Tobias, now I'm left to one last question...are the cluster bulbs of a standard variety that I can get at the local parts store or do I have to call my dealer? Thanks again guys...



------------------
Chris Singh
1983 300D
1993 500SEL brilliant silver w/ AMG monoblock II 19"

http://benz.mp3car.com
http://stormworks.max3d.com
Reply With Quote
  #10  
Old 10-16-2000, 06:42 PM
flipSyde
Guest
 
Posts: n/a
ok, I got the cluster out without a hitch (or a hook ) thanks Tobias. About to go to the parts store to see if they have these curious little bulbs...I'm doubting it, but we'll see. So far so good...

------------------
Chris Singh
1983 300D
1993 500SEL brilliant silver w/ AMG monoblock II 19"

http://benz.mp3car.com
http://stormworks.max3d.com
Reply With Quote
  #11  
Old 11-24-2000, 01:49 PM
Registered User
 
Join Date: Nov 2000
Location: Alameda, CA
Posts: 45
My 92 500SEL also has cluster problems. When using the turn signals or winshield wipers, the instrument lights all flick on and off (reset). My thought is this is a ground issue.
Do anyone think that this can be pulled, cleaned up, and put back or am I looking at a new cluster?
Joel

------------------
Joel P. Davis
1992 500SEL 105K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
gauge problems after removing cluster schumi Tech Help 4 08-07-2004 09:41 PM
Instument cluster question Wasuchi Diesel Discussion 3 06-08-2004 05:49 PM
W.T.B. 88 124 temp gauge or cluster olpos Mercedes Used Parts For Sale & Wanted 2 04-30-2004 02:18 PM
WANTED 300e/124 GAUGE CLUSTER Tab Tanner Mercedes Used Parts For Sale & Wanted 4 02-06-2004 02:52 PM
BIZARRE gauge cluster? Peyton300TD Off-Topic Discussion 27 04-07-2003 09:47 PM



All times are GMT -4. The time now is 03:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page