Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-19-2000, 12:47 PM
Registered User
 
Join Date: Nov 2000
Location: west chicago,il,usa
Posts: 68
The engine idle on my 1992 500sl burbles/shutters after about 30 minutes of
running. I'll be at a light for a few minutes and eventually it will briefly
shutter. The car has 65K miles on it.
MB has been over the fuel injectors and replaced many of them but the problem remains. They suggested I try a different
brand of gas and if that doesn't work, they are thinkg they need to drain and "blow"
gas tank and lines.

Any suggestions would be sincerely appreciated!!!

Thanks!!
Reply With Quote
  #2  
Old 11-19-2000, 10:35 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would have the distributor caps checked carefully. These engines usually do run quite smooth. I hope you are getting a qualified tech to work on this. At some dealers, you are put into a lottery and you could easily get a trainee.

------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
OWNER OF MB AUTOWERKS .COM
Reply With Quote
  #3  
Old 11-24-2000, 04:23 PM
Registered User
 
Join Date: Nov 2000
Location: west chicago,il,usa
Posts: 68
quote:
Originally posted by Benzmac:
I would have the distributor caps checked carefully. These engines usually do run quite smooth. I hope you are getting a qualified tech to work on this. At some dealers, you are put into a lottery and you could easily get a trainee.


its fixed...two cracked disributor caps...awesome!!THANKS!!!
Reply With Quote
  #4  
Old 11-29-2000, 01:53 PM
Registered User
 
Join Date: Jun 2000
Location: Genolier, Switzerland
Posts: 172
Different cause

Wow, two distributor caps! I had a similar symptom, but it turned out to be oil leaking from the engine into a distributor. Required replacing a seal. Cheap part, but expensive work.

Momo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1983 500SL idle control module MarkB83 SL Forum 9 06-18-2004 06:18 PM
83 500SL Idle Speed Puzzler CaptnAl SL Forum 2 05-27-2004 06:33 PM
91 500sl idle lopes for 2 mins Ziad Tech Help 0 11-06-2002 09:03 PM
500SL rough idle Beatle Juice Tech Help 5 06-25-2002 10:58 PM
Where is the idle speed contoler on my gray market 83 500SL? South_Paw757 SL Forum 3 06-04-2002 12:31 AM



All times are GMT -4. The time now is 04:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page