Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-25-2000, 07:30 PM
patsy
Guest
 
Posts: n/a
On a '79 300SD,my cruise control switch works in that it increases the speed of the vehicle but it does not set. Which cruise control component is responsible for setting the speed?

------------------
'79 300SD (340K),'71 VW Karmann Ghia conv.,Toyota '77/'88 Land Cruiser's
Reply With Quote
  #2  
Old 11-25-2000, 07:54 PM
Registered User
 
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
Have you checked the owner's manula for your car? It may be different from mine, but I believe you have to turn it on, by clicking the control arm towards you, and then up (which also accelerates) briefly to set it. Like I said, it may be different on your car, so double check in your manual. You may have a problem with your control arm.

JP Toronto
Reply With Quote
  #3  
Old 11-25-2000, 08:08 PM
Registered User
 
Join Date: Jan 2000
Location: PA
Posts: 5,440
You probably have a bad cruise control card. It is the electronic 'brain' of the cruise system. It is located under the dash near the steering column. It is inside an aluminum box.
Rebuilt units are available for about $150.
P E H
Reply With Quote
  #4  
Old 11-25-2000, 08:51 PM
patsy
Guest
 
Posts: n/a
That is "resume" on mine, I have no "on" setting.
quote:
Originally posted by 420SEL:
Have you checked the owner's manula for your car? It may be different from mine, but I believe you have to turn it on, by clicking the control arm towards you, and then up (which also accelerates) briefly to set it. Like I said, it may be different on your car, so double check in your manual. You may have a problem with your control arm.

JP Toronto



Reply With Quote
  #5  
Old 11-25-2000, 08:56 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
well try it. it can't hurt.

Alon

------------------
'92 300CE
Metallic Black (Blue Flaked) on Parchment
Clear Corners
94-95 Tail-Lights
Debadged
Black Grille Insert
78.5k Miles

Future Upgrades:
Sportline Suspension
17" AMG Monoblocks or EVO II's
Euro Headlights
Performance Chip
AMG Exhaust

Click here to Go To My 300CE Page
Reply With Quote
  #6  
Old 11-25-2000, 09:03 PM
patsy
Guest
 
Posts: n/a
I have yanked that stick every which way for years...I am expecting it to activate while parked any day now!
quote:
Originally posted by Ashman:
well try it. it can't hurt.

Alon






------------------
'79 300SD (340K),'71 VW Karmann Ghia conv.,Toyota '77/'88 Land Cruiser's
Reply With Quote
  #7  
Old 11-27-2000, 02:08 PM
Registered User
 
Join Date: Jan 2000
Location: PA
Posts: 5,440
If you remove the aluminum box with the cruise control circuit card in it, be careful to notice how it is mounted. I couldn't remember how mine went back in and I had to look at the other car to see how to reinstall it. Its tricky. You might wait to remove old until you get the new unit so you R&R at same time.
You don't have to remove the card from the aluminum box because rebuilt card comes inside the aluminum box. When I ordered my rebuilt unit there was a $50 core charge that was refunded when I returned the old unit.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
82 300SD throttle linkage and cruise control waybomb Diesel Discussion 0 12-28-2002 06:52 PM
Cruise Control Supposedly never worked right on my car...???? 190D22 Diesel Discussion 7 12-28-2002 05:13 PM
1993 190e Cruise Control Adventure escarbor Tech Help 1 06-26-2002 12:21 AM
Cruise Amp question MikeTangas Tech Help 5 04-15-2002 10:22 PM
My $2.68 Cruise Control Fix...Search Function Saved $$$ Lance Allison Tech Help 0 09-18-2001 08:12 AM



All times are GMT -4. The time now is 11:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page