Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2000, 02:22 AM
Registered User
 
Join Date: Oct 1999
Location: Memphis
Posts: 189
Hey there,

I just finished installing my Mosselman turbo kit on my 16V. Everything looks great. I made sure everything is connected right and all the parts are there. However, now my car won't even fire. I turn the key and the starter just turns the crank and the rest of the pulleys that are on the belt. The crank is turning and I can hear the pistons moving, but it sounds like something is screwed up in the ignition system somewhere. Mosselman sent me 4 new Bosch "silber" spark plugs along w/ the kit and they are gapped at 0.60mm. Could this be causing something to go wrong? I would think that at least it would try to fire. It sounds as if the coil is not even working. The engine doesn't even sounds like it is getting any spark. Basically, I'm very frustrated right now and would appreciate if anyone could give me some advice.
Reply With Quote
  #2  
Old 11-28-2000, 03:10 AM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
test the coil, change it if you have to. sounds like a no spark issue, though are you sure its not fuel related?

Alon

------------------
'92 300CE
Metallic Black (Blue Flaked) on Parchment
Clear Corners
94-95 Tail-Lights
Debadged
Black Grille Insert
16x7.5 Chrome Speedline 5 Star Wheels
79k Miles

Future Upgrades:
Sportline Suspension
17" EVO II's in 7.5" or 8.25" Width
Euro Headlights
Performance Chip
AMG Exhaust

Click here to Go To My 300CE Page
Reply With Quote
  #3  
Old 11-28-2000, 11:22 AM
Registered User
 
Join Date: Oct 1999
Location: Memphis
Posts: 189
Pretty sure it is not fuel related. Because the way it sounds when I try to turn it over. I'm going to test the spark today. Later and thanks for the reply.

Regards,

Clinton Davis
'86 190E 2.3-16V turbo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
16v lightened flywheel, 3.92 lsd rear end, new radiator AMGmercedes Mercedes Used Parts For Sale & Wanted 1 07-20-2004 12:15 PM
16v parts FOR SALE AMGmercedes Mercedes Used Parts For Sale & Wanted 8 10-24-2003 09:19 AM
2.3 16v, 2.5 16v fuel injection upgrades daveCT Performance Paddock 6 04-16-2003 10:19 PM
190E firing order question DieselGuy Tech Help 7 11-18-2001 09:47 PM
16V not firing (more) Clinton Performance Paddock 1 12-01-2000 12:19 AM



All times are GMT -4. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page