Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-12-2004, 11:45 AM
Registered User
 
Join Date: Dec 2000
Location: Northern New Jersey
Posts: 148
ML electrical problem

1999 ML 320, over the past three years wouldn t start 3 times when weather got cold and wet. Always started within one day when I put a 50 amp jump on it. Dealer couldn t find any problem. Battery new/good, charging system check OK. Stalled out and wouldn t start once. Starter OK. Also ESP/BAS light sometimes comes on and goes back off in a day or two.This is when it usually doesn t start. Electrical power is less. Interior lights dimmer. Fan blows slower. #2 postion on heated seats doesn t work. When the vehicle doesn t start, dash lndicator lights light up in a strange way. Some don t light and others like the high beam indicator is on which is not so when vehicle is going to start. When vehicle won t start there is no power to fan blower and radio. HELP ,owned the ML since new and do not want a vehicle with this type of problem. Been to the dealer 3 times with no luck.

__________________
98 E430(sport), 99 ML 320 (sold) , 05 C 230(sport) Mark
Reply With Quote
  #2  
Old 12-12-2004, 07:55 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
The mechanic will almost have to have the truck in a failed state to diagnose it. Based on what I know about the ML, my best guess would be a bad ignition switch (the electrical portion of the switch).
Gilly
Reply With Quote
  #3  
Old 12-12-2004, 10:41 PM
MLTodd
Guest
 
Posts: n/a
Quote:
Originally Posted by cerbomark
1999 ML 320, over the past three years wouldn t start 3 times when weather got cold and wet. Always started within one day when I put a 50 amp jump on it. Dealer couldn t find any problem. Battery new/good, charging system check OK. Stalled out and wouldn t start once. Starter OK. Also ESP/BAS light sometimes comes on and goes back off in a day or two.This is when it usually doesn t start. Electrical power is less. Interior lights dimmer. Fan blows slower. #2 postion on heated seats doesn t work. When the vehicle doesn t start, dash lndicator lights light up in a strange way. Some don t light and others like the high beam indicator is on which is not so when vehicle is going to start. When vehicle won t start there is no power to fan blower and radio. HELP ,owned the ML since new and do not want a vehicle with this type of problem. Been to the dealer 3 times with no luck.
I know this is very remedial, but have you replaced the battery? most batteries only last about 3-4 yrs. I had the same symptoms a while back, replaced battery and all was fine. One additional issue was the power locks sputtering as I started to unlock them; when I pulled to a stop and started to unlock after placing in park. If you are having this problem as well, consider the battery???
Reply With Quote
  #4  
Old 12-13-2004, 09:19 AM
Registered User
 
Join Date: Dec 2000
Location: Northern New Jersey
Posts: 148
New battery. Was replaced after the first incident even though MB told me the battery was fine.
__________________
98 E430(sport), 99 ML 320 (sold) , 05 C 230(sport) Mark
Reply With Quote
  #5  
Old 12-13-2004, 10:27 AM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Sounds like corrosion on a ground lead or on battery terminals. Starting ability is reduced dramatically when moisture is present on corroded leads.

The fact that other systems aren't functioning indicates something other than an electrical engine component.

I would check the ground lead on the battery first. Not the end on the battery, but the end that is bolted to the chassis.

__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page