Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-29-2000, 12:49 AM
dacia's Avatar
Member of the board
Join Date: Mar 2000
Location: Here.
Posts: 315
Could anyone tell me what should be the exact voltage that the alternator should be charging with? Should this value drop according to the load placed on the system (and if the answer is yes, what is the minimum allowed voltage?) or should the voltage regulator compensate for the extra load?
Would a short inside the battery place an increased demand to the alternator to the extent of damaging it?
Any answer is greatly appreciated.

Reply With Quote
Old 11-29-2000, 08:29 AM
Posts: n/a
That's what a voltage regulator does, regulates voltage regardless of load. A charged battery presents a low load.

With the engine off in a system in good shape will read about 12 volts. If the alternator and regulator are working properly, with the engine running, you will read something in the area of about 13.5 volts or maybe a little more. After discharging the battery a little, the voltage may read around 14 volts, the voltage is increasing to recharge the battery.

Are you having a specific electrical system problem? If so, give more information and I'm sure we can help further.

Good luck,
Reply With Quote
Old 11-29-2000, 01:24 PM
Super Moderator
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,315
The 300E's have an endearing characteristic namely leaving you with a dead battery without the light coming on. You can check and replace the brushes in the alternator fairly easily. I concur with LB's answers about a healthy electrical system.

Reply With Quote
Old 11-29-2000, 03:19 PM
Registered User
Join Date: Nov 2000
Location: Umeň,Sweden
Posts: 46
I have checked my 300E ,because i had a problem with charging.
13.6v - with headlight and almost everything else on.
13.85v - with everything off.

I even tried to rev the engine but voltage is stable.
I have the ke-jetronic with the extra air pump wich compensates low rpm when additional load is on.
I have got a battery from optima "red top"

Reply With Quote
Old 11-29-2000, 08:58 PM
dacia's Avatar
Member of the board
Join Date: Mar 2000
Location: Here.
Posts: 315
Thanks guys for the replies greatly appreciated.
Here is the problem: 10 days ago my alternator seized up so I had it rebuilt, however it was not a complete rebuild just partial (the guy said he changed the bearing and the brushes. A week later it stopped charging and yes the charging light did not come on so I did run the battery down trying to make it to the mechanic. They rebuilt the alternator again this time changing most everything inside.

Here are the charging values:
in the morning with cold engine (high idle): 13.90 volts
after an hour or so driving no load (idle): 13.5 volts
with the headlights on (idle): 12.7 volts
with the heater on (idle): 12.35 volts
When I rev it with load on: 13.15 volts

The voltage in the battery, cold before the morning start, was about 12.5 volts during cranking went down to between 10.98 and 11.3 or so.
I am planning on replacing the battery anyway because it did die completely in the summer, even though it is only a year old, (showed 0 voltage after I disconnected it for two weeks, I was on vacation) however the alternator should still have higher output. Since the brushes, the regulator and the stater is new I am not sure where the problem is.
In any case it is probably a good lesson to have your parts rebuild by a reputable electric shop. Sorry for the long post. Thanks for the help.

Reply With Quote
Old 11-29-2000, 09:08 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
As different year models have different alternators, yours may be at max output. Mercedes realized that the small(65A) that was used until 1990 didn't have enough power. They started using the 80A in 1990. I always recommend the later, & stronger one as a replacement. All that is needed to install the stronger one is the later harness. It costs only $50-$60. The old harness can be modified but requires heavy duty crimpimg tool & resoldering.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 11-30-2000, 11:11 AM
Nick Jamal
Posts: n/a
Hi Alex,
I had similar trouble with my 86 300E (yours is an 86 as well, isn't it?), took MB DOC's advice some months ago, and replaced the alternator with a used 80A unit (with warranty), for next to nothing (about $60). My mechanic modified the harness as described above for next to nothing. So far, so good.
Reply With Quote
Old 11-30-2000, 07:54 PM
dacia's Avatar
Member of the board
Join Date: Mar 2000
Location: Here.
Posts: 315
Thanks guys I will do the same thing and replace the alternator with the higher output unit. I should have done it before I had this one rebuilt though.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
2-way Alarm system needed for 300E MBZ OE Car Audio and Multimedia 1 05-12-2004 02:59 PM
Botched 300E system 350SL4spd Car Audio and Multimedia 0 05-06-2004 03:27 PM
Summer behind the door, another A/C thread Jassper Diesel Discussion 3 04-13-2003 02:47 PM
300E Cooling system / Tranny Problem robi99 Tech Help 2 01-13-2002 08:37 AM
300e alarm system - false alarms John H Tech Help 9 04-17-2001 07:40 PM

All times are GMT -4. The time now is 06:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page