Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-30-2000, 09:32 PM
dacia's Avatar
Member of the board
Join Date: Mar 2000
Location: Here.
Posts: 315

Is there a way to check if the voltage regulator is working properly? It is easily replaceable, however I would like to test it before changing it for a new one (the brushes had been replaced, however the output is still low).
Thanks for your advice,

Reply With Quote
Old 12-01-2000, 09:23 AM
Posts: n/a
If your voltages are about 13.5 with engine runnig, the regulator is working okay.

Good luck,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebadging '87 300e emr0591 Detailing and Interior 6 09-04-2007 09:12 AM
Parting Out 300e w124 LOW MILES 6cndmbz Mercedes Used Parts For Sale & Wanted 23 10-06-2003 12:29 PM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 12:14 PM
300E rough rough rough idle MWG Tech Help 21 08-25-2002 09:30 PM
87 300E voltage regulator sach_deva Tech Help 4 02-24-2002 09:39 AM

All times are GMT -4. The time now is 01:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page