Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-03-2000, 10:29 PM
240Joe's Avatar
Registered User
 
Join Date: Nov 2000
Posts: 525
I tried to put my heater fan on high tonight, and I believe that I wasn't working at all. I switched the control a few times, and it started working on high again. I'm not sure if it was working on the low or medium setting either since both of those settings are very quiet in my car.

It might have been my imagination, but it sure seemed to me that something is failing. I'm sure I'll know more in a few days.

Am I correct in assuming that there is some type of relay that feeds the blower on the high setting? If high is the only one not working, maybe the relay is shot. If the fan doesn't work on any setting, then I would guess the brushes might be gone. Any inputs? Are the brushes readily available and is brush replacement possible.

I've replaced the brushes in the alternator, so I can do some minor electrical repair/soldering.

thanks
Joe
Reply With Quote
  #2  
Old 12-04-2000, 11:10 AM
Zoonhollis's Avatar
Diesel Fanatic
 
Join Date: Jun 2000
Location: Cary, NC
Posts: 551
I've replaced the brushes on the blower motor before, and while it's no picnic, it can be done. I went to an electronics shop, and they had an assortment of brushes. I found some that seemed to fit, so I replaced the old brushes, and off she went!
__________________
Matt
------
1995 E300 Diesel (Die Blau Frau)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 Heater Blower jcantor Tech Help 7 01-07-2005 03:56 PM
Heater blower fuse keeps blowing out. help! 280GE Tech Help 6 12-30-2003 01:52 AM
another heater blower question greggyc Tech Help 1 12-13-2003 10:14 AM
Dysfunctional Heater Blower Todd LaRoche Tech Help 6 03-09-2003 01:41 PM
Blower Motor Problem in 1983 240D LoveLEE143 Tech Help 1 05-10-2002 12:37 AM



All times are GMT -4. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page