Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-17-2005, 09:15 PM
Registered User
 
Join Date: Dec 2004
Posts: 2
How do I access Wiper tranmission linkage

1989 560sl --
wiper motor is working, however linkage making noise, loose.

Thanks

Joe

Reply With Quote
  #2  
Old 02-19-2005, 10:26 PM
Registered User
 
Join Date: Aug 2000
Posts: 57
Joe,


If your wiper motor is working and linkage is making noise, most likely it is from the linkage mounting point to the back of the dash. This is a common problem with the 107 body. Access to this is to remove the instrument cluster, it will be to the left, mounted on the cowl. The 10 mm bolt becomes loose over time and if you don't tighten it soon, you get to buy and install a new wiper transmission. Don't put this off------it can become costly


Regards, Perry
Reply With Quote
  #3  
Old 06-15-2005, 09:46 PM
Registered User
 
Join Date: Oct 2001
Location: Raleigh, NC
Posts: 6
I have the same problem with my 87 560SL, but I understand that to remove the cluster, the steering wheel has to be removed. To remove the wheel, the SRS has to be deactivated, and I have been told that this is potentially dangerous. Is this true? How does one safely deactivate the SRS in order to remove the steering wheel?

TIA,
Walt
__________________
'87 560 SL
Reply With Quote
  #4  
Old 06-16-2005, 01:41 AM
Registered User
 
Join Date: Apr 2005
Location: FL
Posts: 71
disconnect battery, pull fuse for airbag, if equipped. wait 10 min. then you can remove the airbag from the steering wheel. be careful not to mangle the contacts behind the airbag. the airbag can not go off if there is no power present.
__________________
"the simplest answer is usually the correct answer"

1991 190e, 2.6 (helga)
91,000 mi
Reply With Quote
  #5  
Old 06-16-2005, 08:19 AM
Registered User
 
Join Date: Oct 2001
Location: Raleigh, NC
Posts: 6
Thanks for the reply, Aqua190!

Walt

__________________
'87 560 SL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to access wiper motor on W124? 400E Tech Help 2 01-17-2005 12:00 PM
Need new W126 Wiper linkage cam69ss Tech Help 0 05-19-2004 01:25 PM
Wanted: W116 Wiper Linkage cam69ss Diesel Discussion 0 11-25-2003 09:24 AM
Wiper Linkage TN-W124 Diesel Diesel Discussion 0 08-10-2003 08:04 AM
Wiper Linkage TN-W124 Diesel Diesel Discussion 1 08-03-2003 06:11 PM



All times are GMT -4. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page