Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-23-2000, 10:10 AM
AV AV is offline
Registered User
Join Date: Jan 2000
Location: Toronto,Ontario
Posts: 130
I have a friend who has a 300E /1991 and this morning he called me to find out why his engine has a knocking noise when cold and it goes away when it warms up?Any ideas ??
His car has 140000miles and and otherwise seems fine.

His description is like a rod or bearing,Anybody experiance this.He bought the car in the summer.
88 300E/Debadged and Monotoned
Euro light conversion
Clear corners
Performance muffler..(love itttttt!!)
White Gauges by Chris Henkel
alpine CD am/fm,Fosgate amp,Nakamichi sub ported in cabin,Fosgates separates.

Reply With Quote
Old 12-23-2000, 08:54 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Mine did this off and on for the whole winter. I think that when the engines get some miles on them, they will have some carbon deposits. When they sit, the pistions can come into contact with outside air if that exhaust valve is open. The carbon can then release from the piston because of drying out and then it will knock for a minute or two...

Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
knocking noise from front passenger wheel area sunil190e-1.8 Tech Help 5 05-24-2003 08:56 AM
Whistling noise when cold starting 97 E420 tmorales Tech Help 0 07-09-2002 10:07 AM
knocking noise osamen Tech Help 0 07-08-2002 07:12 PM
Noise from water pump when cold MitchLampson Tech Help 6 04-19-2001 07:27 PM
300e cold start & lifter noise steve rush Tech Help 3 05-25-2000 05:37 AM

All times are GMT -4. The time now is 10:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page