Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-21-2005, 02:42 PM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
C240 112912 engine code emergency help needed!

my dads 1999 45k mls C240 with 2,6l 112912 engine has recently developed a strange problem. when you hit the accelerator hard the check engine light comes on and the engine loses power like it is not running on all cylinders. this stumbling goes away when we stop and restart the engine(however the check engine light stays on). our indie took it to MB to read codes and and it threw every code from plugs to coils, O2 sensors right side, brakeassistant and so on.....so MB wants to start with coils, but the engine is running fine as long as you don't push gas too hard... what about cat? only cylinders 1 3 5 have problem. anybody out there had a similar problem? where should we start????
cheers,
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #2  
Old 04-21-2005, 05:24 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Exclamation

Most common problem is a VERY lean mixture under load, fuel presure problem(filter) or defective air mass sensor returning incorrect voltage signal!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-21-2005, 10:37 PM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
Thank you MB DOC.Will check fuel filter and swap AMM with known good one from my recently aquired E240. My 320 Coupe died in the last snow a neighbour slid into it with his SUV. Will post outcome...
Thank you,
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #4  
Old 04-22-2005, 02:43 PM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
swapped AMM with no result. how would i check fuel filter and where is it located??? any other suggestions? could it be one of the cats?
thank you,
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #5  
Old 04-22-2005, 08:16 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
may want to try the forum at

I have a question, when you hit the gas and the engine balks what happens to the tachometer? rpm needle falls to zero immediately or the needle stumbles downward?

when were your spark plugs changed? and the wires - have you checked them with a volt/ohm-meter for resistance.

Is your car running the original battery?

After you swapped AMM did you disconnect the battery in an attempt to clear codes/CEL light?

Also check for a vacuum leak around the intake; throttle body, manifold.

Fuel injection - you need a manual to diagnose that, but I would do new spark plugs and wires, and if that didn't work would check the fuel injection starting at the fuel filter.
Reply With Quote
  #6  
Old 04-23-2005, 01:31 AM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
nothing happens with the tach it just showe the speed, plugs changed 10000mls ago, i did not diconnect the battery and it is OEM mercedes.
i have not measured plugs and wires yet. what should be the resistence??
thank you,
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #7  
Old 04-23-2005, 08:15 AM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
I don't know how well the HT wires test with ohm/volt-meter, but if you pulled them out you can just see if they are all within a range.

I would set the ohmeter to the R x 100 scale - touch probes together and zero meter. Then touch probes to both ends of wires.

I kind of thought that mercedes diagnostic equipment could find the fault in the ignition if there was one.
Reply With Quote
  #8  
Old 04-23-2005, 08:35 AM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
May I suggest you try a new crank position sensor.

My reasoning behind this- 2 weeks ago I had a 2002 ML320, 112 engine, If you drove it like grandma, it was ok, if you punched the accelerator, cyl 6 misfired and it shut down the cylinder. It had been to another shop twice for this problem, they had replaced spark plugs, coil, wires and injector for that cyl, and even replaced coil, plugs and wires for cyl 1 as well. When I got it a month later, I tried driving it with the exhaust off, a new air mass, inspected all the plugs again, ohmed out the wires, checked coil signals on oscilloscope, tested spray pattern of new injector, reset mixture and ring gear adaptation, checked timing of engine, removed valve covers and checked for weak or broken valve springs- finally thought what the hell, I'll stick a crank sensor in it. That did the trick, of course it was going to be the last thing I tried.
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #9  
Old 04-24-2005, 08:09 AM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
wanted to take the car to mechanic today- on the way i thought i woul try to put it into limp mode- it would rev fine. two more start and the check engine light is out. drove car for 30 mls and it runs perfect. miraculous self healing????? my dad takes a trip today; we will see...
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
  #10  
Old 04-24-2005, 12:04 PM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
its possible. theres a magic number something like if it doesn't see the problem after 40 starts, it will erase the code on its own.
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #11  
Old 04-30-2005, 12:52 AM
Registered User
 
Join Date: Aug 2003
Location: Vienna
Posts: 74
had the car at mechanic- ECU readout now showed crank sensor-replaced.engine is running fine so far. in addition he found a vacuum leak in the break pressure system.
cheers,
reinhard
__________________
E 240 2000
E 320 Coupe
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine....error code 441 mafiose Tech Help 5 12-31-2005 09:27 PM
Non-functioning Emergency engine shutoff valve pberku Tech Help 0 04-01-2004 11:59 PM
Emergency Engine shut-off pberku Diesel Discussion 6 01-28-2004 08:16 PM
Trouble code reader for 103 engine ctaylor738 Tech Help 7 09-03-2003 08:10 PM
Engine Idling to high Plz help! Emergency MercedesOwner Tech Help 8 06-29-2003 01:38 PM



All times are GMT -4. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page