Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-28-2005, 10:08 PM
Registered User
 
Join Date: Apr 2005
Location: springfield, missouri
Posts: 2
1990 500SL wet running problem

Before I blow this thing up, I thought I would check with you guys. Here is my problem. I am running down the road, it starts raining and in a matter of time my engine will die. It will start back up and idle but if you touch the gas or just put it in gear, it goes dead. I have noticed also, that my climate control always goes to automatic when I restart the engine, after I have turned it off. I have spent a lot of money at different shops and no one can fix it. HELP!!
Reply With Quote
  #2  
Old 04-29-2005, 08:34 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Question

Wet running problems are almost always secondary ignition related!

WHAT has been replaced as far as ignition system, caps/rotors/wires/coils???
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-29-2005, 01:55 PM
Registered User
 
Join Date: Apr 2005
Location: springfield, missouri
Posts: 2
1990 500 SL wet runner

I have replaced these items:
Plugs
Cam Sensor
Ignition cables
dist caps and rotors
coils
crank position sensor

The weird thing is, you can squirt a hose right on everything and it won't kill it. Then if it sits awhile with the hood closed it does it.
Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 sl500 starting problem dinnyjoe Mercedes-Benz SL Discussion Forum 14 08-29-2012 02:49 AM
Door Panel 1990 500SL slor911 Mercedes-Benz SL Discussion Forum 3 05-17-2003 11:59 AM
1990 190E 2.6 oil pressure problem... uh-oh! blackmercedes Tech Help 4 11-28-2002 10:20 AM
Request: Picture of radio removal keys for 1990 500sl chad500sl Car Audio and Multimedia 2 11-14-2002 11:27 AM
1990 500sl gets confused between hard and softtop chad500sl Mercedes-Benz SL Discussion Forum 1 05-27-2002 07:16 PM



All times are GMT -4. The time now is 09:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page