Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-12-2005, 02:32 PM
Registered User
 
Join Date: Sep 2002
Location: Ewa Beach, Hawaii
Posts: 333
86' 300E rough idle & hesitation resolved!!!

Just wanted to post this for those with the same problems. I'm an average DIY guy and try to fix the minor things with my car, but sometimes I take it to a mechanic when I can't figure it out myself.

Anyway, lately my car would idle roughly and sometimes it felt as if it was struggling to accelerate. I though it was the fuel pump & filter, so I changed that....guess what....no improvement. GREAT. That put a $300 hole in my pocket.

I was going to start replacing the sensors and relays, but that could cost too much. I figured that maybe it would be better if I just brought it to a mechanic.

Anyway the first time I brought it in, he tested the fuel line, cleaned out the injectors, then changed the oxygen sensor. He had a hard time diagnosing the car's problem because the problem was intermittent. Anyway his "fix" cleared things up a bit, but after a few weeks, the problem came back even worse. I brought the car back to him and he "scoped" it. Turned out to be a bad coil. The spark plugs were changed too (They were over a year old anyway).

I should have brought it in to the mechanic in the first place. Damn it! Well, at least I've learn more about my car. The fuel pump was noisy (sign of impending failure) anyway so I guess it's o.k. that I've changed it.

I hope this experience will help others clear up their problems.
__________________
JR
1986 Gold 300E 4Dr automatic
Reply With Quote
  #2  
Old 05-12-2005, 03:06 PM
Registered User
 
Join Date: Nov 2001
Location: California
Posts: 39
That's great news, now if I could just figure out my gremlins.
__________________
Shoebox
Reply With Quote
  #3  
Old 05-15-2005, 11:49 PM
lino's Avatar
Registered
 
Join Date: Jun 2004
Location: Canada
Posts: 981
Do you hapen to know why the newer W124 cars came equipped with 3 coils instead of 1?

I haven't changed mine before. Maybe I should put an ignition coil on my "parts to buy" list too.
__________________
1989 300CE Astralsilber/Schwarz
1992 300CE Schwarz/Schwarz
Reply With Quote
  #4  
Old 05-16-2005, 12:26 AM
wbain5280's Avatar
Registered User
 
Join Date: May 2001
Location: Northern Va.
Posts: 3,386
Newer 124's use the M104 with uses 3 coils for fire 6 plugs with no distributor cap. They are electronically fired. The earlier M193 uses one coil and a dist. cap.
__________________
Regards

Warren

Currently 1965 220Sb, 2002 FORD Crown Vic Police Interceptor

Had 1965 220SEb, 1967 230S, 280SE 4.5, 300SE (W126), 420SEL

ENTER > = (HP RPN)

Not part of the in-crowd since 1952.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal bulb out? and rough idle on 300e dirtysocks Tech Help 13 04-23-2004 01:30 AM
E320 Rough Idle / Egr Problem earossi Tech Help 13 09-22-2003 09:14 AM
Hard cold starting, rough idle 89 300E JAlex Tech Help 1 05-16-2003 03:49 AM
Rough Idle Shakey Engine And Hesitation dknyliquid Tech Help 0 03-08-2002 02:31 PM
Rough Idle on 300e MikeC Tech Help 6 04-29-1999 08:13 PM



All times are GMT -4. The time now is 10:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page