Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-09-2001, 09:08 AM
Alan S's Avatar
Registered User
Join Date: Dec 2000
Location: Cary, IL
Posts: 94
Whenever I'm in the automatic mode using the climate control, and the fan goes up to high, both my headlights and cockpit lights brighten, it's nothing dramatic, but certainly noticeable. I tried to reenact by manually placing the fan switch to high, but my lights didn't brighten. Then I tried to vary engine rpm to see if that had anything to do with it, nope. Is this a sign of something starting to fail? On a similar note, my climate control fan operates intermittently, when it works it works, when it doesn't, it takes a while for it to decide to come on, and that's both in manual and automatic. I read somewhere that it could be linked to my ignition switch? any ideas? Car is an 84 380SE, Thanks again for everyone's help.
2012 550CLS
1982 380SL
1985 300D
1998 ML-320
1997 E-320
1984 380SE
Reply With Quote
Old 01-09-2001, 12:18 PM
Registered User
Join Date: Mar 2000
Posts: 517
If the blower motor fails to operate following engine start, try turning the ignition key slightly to the left. Should the blower motor suddenly engage (and you can repeat this effect) then your ignition switch requires renewal (# 202 545 01 04; approx $22.00)

If the motor fails to operate, remove the right lower dash access panel (3 chrome screws and two grey plastic clamps) and firmly rap on the blower motor housing. If the motor starts, then the brushes are likely worn. Remove the motor (4-5 screws?) and inspect. If only the brushes are worn then consider renewing them (replacement brushes are available from aftermarket sources). If anything else is worn/damaged, then consider renewing the motor.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Interior Lights in 190E JohnnyAl Tech Help 5 12-19-2003 03:34 PM
Mein E-code lights are in!!!! MikeTangas Tech Help 13 11-16-2002 04:24 PM
300E Euro Lights Impressions anm Tech Help 5 01-29-2002 01:15 PM
Euro Headlights DZLPWR Diesel Discussion 10 10-07-2001 12:03 PM
Quick Cibie question....... DieselHead Diesel Discussion 3 09-21-2001 04:38 PM

All times are GMT -4. The time now is 05:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page