Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-2005, 11:30 AM
Enjoys driving MB
 
Join Date: Nov 2004
Location: Sweden
Posts: 50
Question 190E 2.6 dies when rolling on idle??

I have the problem that my 2.6 dies when i rolling with the it on idle, doesn't matter if I'm rolling forward or backward with that bloody bastard.... this happens if i have no gear no clutch, clutch no gear, gear and clutch

I've checked the TPS, The EHA, the idling switch and so on, ground connections is also checked...

the lambda sond gives an constant voltage@~400milliVolts.. is the CO-settings out of range or are the sond broken? I know that the sond shall give a fluctuating voltage between 0.1 and 0.9 volts

the exhaust has lo leaks
__________________
Patrik Nilsson -83
230CE -88
230TE -87
http://www.hastonnet.se/putte/avatar-new.jpg
Reply With Quote
  #2  
Old 06-10-2005, 04:22 PM
Enjoys driving MB
 
Join Date: Nov 2004
Location: Sweden
Posts: 50
heeelp!! Im getting mad the lambda sond has been changed today, still same problem....
__________________
Patrik Nilsson -83
230CE -88
230TE -87
http://www.hastonnet.se/putte/avatar-new.jpg
Reply With Quote
  #3  
Old 06-10-2005, 04:45 PM
Registered User
 
Join Date: Jul 2004
Location: York, PA
Posts: 621
I would clean the Idle Air Control Valve and test the switch on the end of the throttle linkage. Also clean the AFM plate as well. Check for vacuum leaks as well.
__________________
~Jamie
_________________
2003 Pewter C230K SC C1, C4, C5, C7, heated seats, CD Changer, and 6 Speed. ContiExtremes on the C7's.

1986 190E 2.3 Black, Auto, Mods to come soon.....
Reply With Quote
  #4  
Old 06-10-2005, 04:49 PM
Enjoys driving MB
 
Join Date: Nov 2004
Location: Sweden
Posts: 50
I have checked everything like that. The problem is not there

can it be the generator?
__________________
Patrik Nilsson -83
230CE -88
230TE -87
http://www.hastonnet.se/putte/avatar-new.jpg
Reply With Quote
  #5  
Old 06-10-2005, 05:07 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,359
OVP(overvoltage protection relay) provides power to the idle control circuit. Something else to consider.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #6  
Old 06-11-2005, 04:39 PM
Enjoys driving MB
 
Join Date: Nov 2004
Location: Sweden
Posts: 50
the ovp has been changed for about 2 months ago, sometimes the engine (when idle) rush up to 1.5-2kRPM for some seconds and back to normal idle again
__________________
Patrik Nilsson -83
230CE -88
230TE -87
http://www.hastonnet.se/putte/avatar-new.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 190E Poor idle JS911S Tech Help 6 05-03-2005 01:32 PM
190E 2.6 info needed pentoman Tech Help 6 01-31-2005 07:53 AM
190E 16v vs. 190E 2.6 Sportline Question ke6dcj Performance Paddock 6 09-03-2004 04:20 PM
3.0 into 190E 2.6 neileg Tech Help 2 11-01-2002 11:30 AM
Is there a worthy replacement for the 190E 2.6? Marsala Featured Cars 15 06-04-2002 08:12 AM



All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page