Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-11-2005, 04:07 PM
Registered User
 
Join Date: Dec 2003
Posts: 5
Lightbulb 96 C280 CEL and Instrument Cluster Question

Check Engine Light is on. OBD2 generic scanner gives code P0600 (Serial Comm LInk Fault). Any help where to begin? Which module SFI, DM, etc is not communicating on the CAN bus? Major (replace module) or Minor (resistance or ground problem)?

Just curious is it normal to have the LED panel lights stay on indefinately? The odometer/trip odemeter, clock, ambient temp LEDs stay on overnight? Any ideas what might be problem if this isn't normal? Ignition Switch checks out OK... TIA

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster unctarheels01 Tech Help 1 04-24-2005 07:59 PM



All times are GMT -4. The time now is 03:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page