Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #31  
Old 06-23-2005, 05:49 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
I've mis-placed one of the screws that attaches my EHA to the fuel distributor. It's holding .. for now, but if anyone in this thread has replaced theirs and has an extra, I'd gladly pay for it. (dealer only sells it with the EHA)

If you do, please email me at pmizell@gmail.com

Thank you very much!

__________________
-Paul-
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
  #32  
Old 06-24-2005, 12:31 PM
Registered User
 
Join Date: Nov 2004
Posts: 79
If my used EHA comes with screws, I'll send you one!
Mika

Quote:
Originally Posted by pmizell
I've mis-placed one of the screws that attaches my EHA to the fuel distributor. It's holding .. for now, but if anyone in this thread has replaced theirs and has an extra, I'd gladly pay for it. (dealer only sells it with the EHA)

If you do, please email me at pmizell@gmail.com

Thank you very much!
Reply With Quote
  #33  
Old 07-19-2005, 12:18 PM
Registered User
 
Join Date: Nov 2004
Posts: 79
OK, I finally replaced the EHA. I even replaced the plugs, which were pretty caked in sticky soot. The car runs now, but very poorly. At idle, there seems to be a rythmic 'miss.' If I punch the gas, the engine stumbles before gaining rpm. The engine will run smoothly above 4K RPM, but practically stalls when I let off the gas. If there is any load on the engine (ie, if I put the car in drive) it stumbles a lot. I don't think it's driveable.
I'm about ready to give up and just sell the car as is, but I'd be interested in any other suggestions that might help fix my problem.
The things I have NOT yet done:
- Replace O2 sensor (I have a new one, just haven't installed it. Mechanic told me the old one is bad)
- Checked Lambda control. Does this work on my car (86 300E) just as described in the link?
http://www.landiss.com/mixture.htm
Any other thoughts before I toss in the towl and wash my hands of this?
Thanks,
Mika

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190e running rich with eha on/off.Bad mpg.Help! azhari Tech Help 87 11-01-2021 04:15 PM
Fault Code 9 – EHA Current illogical Tony Smith Tech Help 25 11-19-2012 07:43 AM
The times when I hate computers. Diesel Power Off-Topic Discussion 11 01-22-2005 04:40 PM
Fuel lines leaking -- how to get it all the way back on? webwench Tech Help 6 10-20-2004 07:48 PM
What is the purpose of the EHA? AusMB Tech Help 3 04-16-2001 06:18 AM



All times are GMT -4. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page