Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-25-2005, 11:15 AM
Registered User
 
Join Date: Aug 2005
Posts: 1
Hard Starting Problems 2000 C230

I have 2000 C230 4 cylinder model with 50,000K miles. Just recently it has been starting hard. I have spent over $400 for new plugs, fuel system flush and filter. I have also spent over $500 for a new mass air flow sensor. It now starts fine after previously running but still starts a little hard when starting after it has been sitting for a while like overnight. The mass air flow sensor was the only code reading under the diagnostic which is why it was replaced. The technician's seem stumped. Any ideas?

Reply With Quote
  #2  
Old 08-25-2005, 09:41 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
who did and what is a fuel system flush.

has the fuel pressure been tested? like first thing in morning

How old is your battery? those suckers like to be changed ( or tested and serviced ) every four years
Reply With Quote
  #3  
Old 08-25-2005, 09:49 PM
Registered User
 
Join Date: Aug 2005
Posts: 64
I would put a fuel pressure tester on the thing and let it sit over night. Most likely it is losing fuel pressure after sitting for an extended period of time. Maybe a bad o ring in the fuel pump/sender assembly. I've seen this on the newer c class cars, and have replaced both the left and the right fuel senders to resolve the problem.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W210/E320 hesitation & starting problems benzthere Tech Help 8 07-25-2005 01:46 AM
Hard Starting Sonny Aranas Tech Help 0 06-21-2003 01:39 AM
Hard cold starting, rough idle 89 300E JAlex Tech Help 1 05-16-2003 04:49 AM
420 SEL Starting Problems + Low idle etc xsohaib Tech Help 6 05-08-2003 05:38 PM
If your 190E is experiencing hard starting.. pmizell Tech Help 0 06-30-2002 02:17 PM



All times are GMT -4. The time now is 08:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page