Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-27-2001, 01:06 AM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
How can I tell (technical or otherwise)if this pump is working or not. Thanks.

MDoc I know you can help me with this Thanks.

[Edited by yal on 02-27-2001 at 02:14 PM]
Reply With Quote
  #2  
Old 02-28-2001, 12:32 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
MDOC, Benzmac, anybody?
Reply With Quote
  #3  
Old 03-01-2001, 08:42 AM
LarryBible
Guest
 
Posts: n/a
The operation of this pump is rather transparent. I don't even know the logical conditions involved.

I know how to check the pump, but I wouldn't know how to check to see of the power to the pump is there because I don't know exactly how to turn it on to check for power.

It is important for you to know that if the pump goes bad it will start drawing more current and probably will blow the pushbutton control unit in the dash.

To check the pump current draw, disconnect power to the pump and apply power through an ohmmeter to the pump, you should here it operate and should draw no more than 1.3 Amps.

Good luck,
Reply With Quote
  #4  
Old 03-01-2001, 11:40 AM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
Thanks LarryB you're a life saver, i'll give it a shot, my buddy has an old ohmmeter.
Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.3 8 V Water Pump Replacement mctwin2kman Tech Help 5 08-22-2004 03:59 PM
OK, what did I do wrong? (201 2.3 water pump) haasman Tech Help 4 02-10-2004 02:51 AM
300E leaking coolant near water pump mike690003 Tech Help 4 08-04-2003 08:30 AM
84 380sl augsilary water pump litletrees Tech Help 0 09-17-2002 09:43 PM
auxillary water pump? The Bob Tech Help 6 07-18-2001 03:28 AM



All times are GMT -4. The time now is 04:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page