Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2001, 08:27 PM
Marexke
Guest
 
Posts: n/a
Hi guys

Problem on a M.B.W126 280SE 1985 KA JETRONIK

The problem was a bend intake valve!
Probably I did something wrong before mounting the head and turned the cams separately so that one valve bended the other…and needed to be replaced!
Now that is resolved, the engine runs, but to fast (1500 rpm)
I tried everything but cannot get a lower idle, what to do?
Any suggestions?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What type of balance weight should I get. blau Wheels & Tires 2 11-09-2004 10:49 PM
loop to pin type glow plug converters JMH Diesel Discussion 7 01-03-2004 08:39 PM
Kill Story. Acura RSX type S vs. My turbo 190E 16V.(LONG) Clinton Performance Paddock 8 02-04-2003 07:09 PM
Specific Question on Type II ACC someguyfromMaryland Tech Help 4 12-23-2002 08:58 PM
Are Borbet Type E rims AMG replicas? MUYAMAN Wheels & Tires 3 07-31-2002 04:34 PM



All times are GMT -4. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page