Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


  Join us November 1st for Casino Night at the Pelican Parts Open House!
Benefiting LuMind - Research and Treatment for individuals with Down Syndrome
Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-28-2006, 05:34 PM
Registered User
 
Join Date: May 2006
Posts: 5
Unhappy stuck in first gear

CRAP,
I'm stuck in first and my 1998 c280 won't shift into a higher gear? Does this mean my throwaway transmission needs to be thrown away? or is this an easier/cheaper fix. This started happening a month ago but usually turning off and restarting the car would fix the problem? also it would idle choppy, but now that it's stuck in first it idles fine. Can anyone tell me what the problem sounds like? applejuiceboy
oh by the way this is an automatic
Reply With Quote
  #2  
Old 05-28-2006, 05:37 PM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by applejuiceboy
CRAP,
I'm stuck in first and my 1998 c280 won't shift into a higher gear? Does this mean my throwaway transmission needs to be thrown away? or is this an easier/cheaper fix. This started happening a month ago but usually turning off and restarting the car would fix the problem? also it would idle choppy, but now that it's stuck in first it idles fine. Can anyone tell me what the problem sounds like? applejuiceboy
oh by the way this is an automatic

have you checked the fluid level? i have seen low fliud on a 722.6 cause no upshift. do you have the tool to check the level? use mercedes fluid to top off
Reply With Quote
  #3  
Old 05-28-2006, 05:50 PM
Registered User
 
Join Date: May 2006
Posts: 5
no dipstick

my manual says there is no dipstick, that a mercedes dealer would have the ability to check that. it also says there is a permanent fill of automatic transmission fluid.
Reply With Quote
  #4  
Old 05-28-2006, 05:52 PM
Registered User
 
Join Date: May 2006
Posts: 5
no i don't have the tool. thanks for your response, i hope that's the only problem
Reply With Quote
  #5  
Old 05-28-2006, 05:55 PM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by applejuiceboy
my manual says there is no dipstick, that a mercedes dealer would have the ability to check that. it also says there is a permanent fill of automatic transmission fluid.
permanent it is not, but that is a whole other story. if it has a leak then the fluid level will drop. you can buy the tool at the link below for less than mercedes would charge

http://catalog.eautopartscatalog.com/mercedesshop/sophio/wizard.jsp?partner=mercedesshop&clientid=catalog.mercedesshop&baseurl=http://catalog.peachparts.com/&cookieid=1SZ00P8ES1TA12CZGQ&year=1998&make=MB&model=C-280-002&category=All&part=AT+Dipstick
Reply With Quote
  #6  
Old 05-29-2006, 06:11 AM
MLC MLC is offline
Registered User
 
Join Date: Dec 2004
Posts: 9
check vacuum modulator?

bad idle can be caused by a vaccum leak, and not shifting up properly can be caused by a leaky vacuum modulator or at least a leak in the pipe running to it. does it shift up at all? in my (mostly non-benz) experience the trans will still shift to higher ratios but not until the revs are way higher than normal - at full throttle and nearly to redline.
Reply With Quote
  #7  
Old 05-29-2006, 11:45 AM
C32AMG's Avatar
Registered User
 
Join Date: Mar 2004
Location: new york/orange county
Posts: 639
Your model car has a 722.6 transmission, scan ALL Modules for codes, also the early 6th generation transmission suffered from TCM harness fluid contamination, and check the connector plug on the transmission for fluid.
Reply With Quote
  #8  
Old 05-29-2006, 12:03 PM
Registered User
 
Join Date: May 2006
Posts: 5
thanks

thank you, very helpfull
Reply With Quote
  #9  
Old 05-29-2006, 02:03 PM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by MLC
bad idle can be caused by a vaccum leak, and not shifting up properly can be caused by a leaky vacuum modulator or at least a leak in the pipe running to it. does it shift up at all? in my (mostly non-benz) experience the trans will still shift to higher ratios but not until the revs are way higher than normal - at full throttle and nearly to redline.

the unit he refers to is completely electronic, it doesn't have a vacuum modulator installed.
Reply With Quote
  #10  
Old 05-29-2006, 07:29 PM
Registered User
 
Join Date: May 2006
Posts: 5
i drove it a little today, tried to almost redline it, and still no shifting
Reply With Quote
  #11  
Old 05-29-2006, 09:20 PM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by applejuiceboy
i drove it a little today, tried to almost redline it, and still no shifting
why would you do that?? that isn't going to fix it. check the fluid level then get back to us.
Reply With Quote
  #12  
Old 06-07-2006, 12:31 PM
Registered User
 
Join Date: Jun 2006
Posts: 2
Same problem in an '86 Mercedes 560SEL, maybe

It is temperamental... sometimes it shifts normally and then other it just stays in a low gear...won't upshift. If I stop and go thru the gears it sometimes will work and at other times while it seems to be shifting normailly it will downshift suddenly and gear the car down when I am going at a higher speed.. I just tooki it to a transmission specialist and he is stumped.. any help here is appreciated..
Reply With Quote
  #13  
Old 07-13-2006, 08:06 PM
Registered User
 
Join Date: Mar 2003
Posts: 29
Ask your mechanic to replace the so called "Range Recognition Switch", it's in the shifter unit, cost about $100 and an hour or so to replace. Reading the ECU and TCU won't show, unless you connect the StarDiag to it, and manually shifting between difference gear and read back the RangeReg switch.

Until you fix it, while you're driving, if car stuck in first gear, jiggle the shifter the unit a bit (but not to shift it back to nertral and back) will fix the problem

Very common problem on the pre 2000 mercedes

Quote:
Originally Posted by rons
It is temperamental... sometimes it shifts normally and then other it just stays in a low gear...won't upshift. If I stop and go thru the gears it sometimes will work and at other times while it seems to be shifting normailly it will downshift suddenly and gear the car down when I am going at a higher speed.. I just tooki it to a transmission specialist and he is stumped.. any help here is appreciated..
Reply With Quote
Old 07-13-2006, 08:06 PM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page