Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-08-2001, 09:22 PM
Dave Horvath's Avatar
Registered User
Join Date: May 2000
Location: Ohio
Posts: 132
i have had problems with my 84 300d not turning off in the past. i thought that it had something to do with the vacuum shutoff for the injector pump, but i just replaced it and the lines to the key still flood with oil. any ideas what it might be?
thanks in advance
Reply With Quote
Old 04-08-2001, 09:42 PM
Dave Horvath's Avatar
Registered User
Join Date: May 2000
Location: Ohio
Posts: 132
i havent experienced any problems with brakes or locks.....just the lines filling with oil
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
We often overlook Fuel Pump damage--Low Sulfur Fuels and bad fuel (85 300D) Carrameow Diesel Discussion 16 11-15-2007 05:43 AM
Opinions on purchasing a 1987 300D swogee Diesel Discussion 12 05-03-2005 10:27 AM
1976 W115 300D motor into 1979 W123 300D sebtowne114 Diesel Discussion 5 04-14-2005 07:26 AM
auto tranmission problem in 1981 300d o2pilot Diesel Discussion 2 06-15-2004 11:19 AM
300D turbo slushbox vs 300D n/a 4 speed The Warden Diesel Discussion 5 05-28-2004 12:40 AM

All times are GMT -4. The time now is 11:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page