Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-11-2001, 09:43 PM
Registered User
 
Join Date: Nov 2000
Location: Gaithersburg, Md
Posts: 40
Hey,
I have a 88 260E and my fuse used to always blow after keeping the windshield wiper on for too long. Now the fuse blows 2 seconds after I turn it on. If I turn it on and off quickly then after about 25 times it makes it to the other side. I was wondering if anyone knew how to fix this problem. It shouldn't be the motor because the wiper moves. Any help would be appreciated. Thanks
Blackbenzz
Reply With Quote
  #2  
Old 04-11-2001, 09:54 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
IT is possible for the motor to be pulling too many amps. I would take out the wiper assembly and check the linkage for binding...Then, if all else is good, replace the motor.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 04-11-2001, 10:30 PM
Registered User
 
Join Date: Nov 2000
Location: Gaithersburg, Md
Posts: 40
Exactly what do u mean by check the linkage for binding? I've never worked on the windshield wiper before. I know its probably a stupid question but I need to get this fixed cuz its really hard to drive in the rain. Thanks for your help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300E 3.2 wiper problem gsl56 Tech Help 10 01-30-2005 11:35 AM
SRS Light & Windshield Wiper Glitch SocksE420 Tech Help 3 12-17-2003 03:28 PM
Windshield Wiper Speed Control - '94 C280 jgl1 Tech Help 0 03-18-2003 01:27 AM
Windshield Wiper Halt diesel don Diesel Discussion 2 10-03-2002 06:03 PM
Friggin weird wiper problem 95E320cab Tech Help 2 08-31-2002 05:24 PM



All times are GMT -4. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page