Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-23-2001, 08:53 AM
engatwork's Avatar
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,234
On my 300D the compressor system works by putting 12 v to the pressure switch circuit. I have been doing some troubleshooting and have found that I am not getting power through this circuit. Has anyone got a schematic that shows where the power is supplied from that they could fax to me? Should one side of the evap temp sensor have power (the black/red wire maybe)? Does the pushbutton console supply the 12 volt power for this circuit? The schematic I have does not go into enough detail to indicate where this circuit "ends". It just shows one end which is at the Klima relay. I am running a new Klima relay.
'85 300D
'95 E320
'97 CRV
Reply With Quote
Old 04-23-2001, 08:16 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Behind the glove box and the vent pipe there is an early over-voltage relay. Check the fuse and replace it.

Good luck.
Donnie Drummonds
Reply With Quote
Old 04-23-2001, 08:50 PM
engatwork's Avatar
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,234
Thanks Donnie,
I went out and pulled it out and the fuse looked good and tested good. I put the Fluke on the relay poles that are shown to be accross the fuse (with the fuse installed) and I did not have a complete circuit. Based on what is printed on the side of the relay it looks like there is a diode in this loop. Have you ever seen one of these relays fail? It got too dark on me to do much more roubleshooting tonite.

For right now I have disconnected the black/red wire from the evap temp sensor and am supplying power to this circuit through a 5 amp fuse and a toggle switch. I use this to turn the compressor on and off while maintaining the protection offered by the evap temp sensor and the freon pressure sensor to shut the compressor down if either of these items get out of spec. Can the push button console cause this type of problem?

I would like to eventually fix it "right". Where can I get a good wiring diagram for this vehicle? Are they available in

'85 300D
'95 E320
'97 CRV
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1985 300D FOR SALE (not mine) Aaron Mercedes Cars For Sale 1 05-10-2004 01:26 PM
300D A/C Evaporator Replacement Shep Diesel Discussion 11 02-29-2004 08:05 PM
1985 300D Terrible Rotten Eggs smell from HVAC system? Carrameow Diesel Discussion 0 04-27-2003 10:30 PM
'85 300D A/C question zachv Tech Help 1 06-15-2002 01:09 PM
300TE A/C Question BENZ-LGB Tech Help 7 06-09-2002 09:13 AM

All times are GMT -4. The time now is 06:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page