Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-17-2006, 04:31 PM
banshee350's Avatar
Registered User
 
Join Date: Apr 2005
Location: SW wash
Posts: 143
buzzing from overhead consol 1999 e300

The little fan that blows air across the temp sensor for cabin temp I am thinking is making a buzz I tried putting a drop of light oil on it and making sure it was clean.Any ideas on a fix or do I have to replace if so do I have to replace the whole light consol?

__________________

89 Ford F3504x4CC 7.3 IDI turboed Intercooler and running on wvo now powered by a 1997 Cumins
87 300SDL on bio and wvo killed by chevy truck 5-24-06
1999 E300TD black with gray int.
Reply With Quote
  #2  
Old 12-17-2006, 05:57 PM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
cabin air temp sensor fan location

Is the fan in the "overhead" or in the "glove compartment" space?

FSM disc I have only goes to 1995 model year.The air pump motor for the
interior temp sensor [In the overhead Light/Sunroof control area] was still
over in the glove box then.
Reply With Quote
  #3  
Old 12-17-2006, 06:06 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
It's overhead.

You might be able to get some oil in there, but it will be tricky. Fortunately, that sensor is very easy to get to in this car.
Reply With Quote
  #4  
Old 12-18-2006, 12:16 AM
banshee350's Avatar
Registered User
 
Join Date: Apr 2005
Location: SW wash
Posts: 143
I have all ready had it out and looked at it, cleaned it , ext. I was woundering if this is a normal problem others have had and if any one knows if I have to replace the hole overhead light assmbly or can just the motor and fan be replaced?
__________________

89 Ford F3504x4CC 7.3 IDI turboed Intercooler and running on wvo now powered by a 1997 Cumins
87 300SDL on bio and wvo killed by chevy truck 5-24-06
1999 E300TD black with gray int.
Reply With Quote
  #5  
Old 12-18-2006, 07:15 AM
Registered User
 
Join Date: Dec 2004
Location: Nashua, NH
Posts: 3,956
Quote:
Originally Posted by banshee350 View Post
I have all ready had it out and looked at it, cleaned it , ext. I was woundering if this is a normal problem others have had and if any one knows if I have to replace the hole overhead light assmbly or can just the motor and fan be replaced?
You can replace the motor/sensor alone. New they are about $75. I replaced mine when I thought the sensor was faulty but there was nothing wrong with it so I kept it as a backup, if you want a good used one you can buy mine for $30 shipped, just PM me for details.

__________________
Marty D.

2013 C300 4Matic
1984 BMW 733i
2013 Lincoln MKz
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page