Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-02-2001, 06:05 PM
Registered User
Join Date: May 2001
Location: Jennings FL
Posts: 2
Engine idles errratically, and when accelerating it will not pick up speed until kickdown comes in. Took it to shop and fuel injectors was replaced alone with regulator. I've had a tune-up with new plugs, fuel filter, air filter, new cap and rotor. I have notice that the backing plate under the dist. cap and rotor has burn holes in it as if it has been arching. could this be the problem?
Reply With Quote
Old 05-02-2001, 06:35 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Do a search on the topic!!!!! What year is your car? How many miles? What about the cables and coil? Did you jumped your car recently? If you did, I would check the overvoltage relay fuse. It is located behind the batttery, it a silver cylindrical box with a red plastic cover/top, it has an "american" type fuse. Are you sure the cap and rotor were replaced?
Start with these simple things, and go from there...
Good luck!!!!!
'86 300E
Reply With Quote
Old 05-03-2001, 06:39 AM
Registered User
Join Date: Apr 2001
Posts: 43
I had a similar promlem with unstable idle on my 300CE and the problem was the idle microswitch.
Remove the air cleaner completely, top and bottom to reveal the throttle linkage. Make sure all the linkage and the switch are clean , mine was covered in oily dirt , then check that the microswitch clicks every time the gas pedal is up.
You may need to bend the switch arm very slightly to make it work every time
Reply With Quote
Old 05-03-2001, 01:38 PM
Registered User
Join Date: Mar 2001
Location: Canada
Posts: 16
I had a similar problem with my 1988 300E, and was solved by cleaning the temperature sensor contacts. Hope this helps.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebadging '87 300e emr0591 Detailing and Interior 6 09-04-2007 09:12 AM
'86 300E vs '91 300E... Any opinions out there??? pjtib Tech Help 23 05-04-2005 09:26 PM
300E FIRST-gear start brewtoo Tech Help 16 03-11-2005 05:27 PM
*CLEAN* W124 Gray MB-Tex Front Seats / 300E 260D 300D (300E 2.8) and (W124 Wagons) FA22 Mercedes Used Parts For Sale & Wanted 5 03-01-2004 08:40 PM
5 speed 300E Idles at 1500rpm vrsmith Tech Help 6 05-01-2002 11:15 AM

All times are GMT -4. The time now is 01:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page