Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-06-2001, 05:31 PM
TomW
Guest
 
Posts: n/a
my c230 was not driven for about 4 weeks and i believe the battery went dead. Nothing was wroking(alarm, lights, etc). I tried to jump start the car but was unsucessful. When I hooked up the jumper cable from my frind's car to mine, the lights came on and others(window, stereo) seem to work. When I turn my key to start it, it just makes strange noise and won't start. What can I do to get out of this trouble? Bad ignition? Loose conncetion? thanks for your help.

ps: i heard placing shift gears in different position can help??
Reply With Quote
  #2  
Old 05-06-2001, 08:29 PM
Registered User
 
Join Date: May 1999
Location: New Location: VA Palo Alto HEALTH CARE SERVICES
Posts: 109
Tom, ..charge the battery or replace it with the correct cranking amps. It seems that it doesn't have enough juice to crank the engine. Now, ..if the engine starts up, ..check your alternator for proper operation. Make sure that it is charging the battery. A reading of 13.8 V or greater is an indication of proper charging. Let me know what you found out.....
Reply With Quote
  #3  
Old 05-07-2001, 02:13 PM
TomW
Guest
 
Posts: n/a
mine is 97 with the switchblade key. I charged my battery long enough(20minutes) before i attempted to turn the key to start the car. At first, it sounded like the car would start right away. But, the car shakes for about 3 secs (while turning the key clockwise) and the noise sort of fades away. The battery is relatively new. Thank you for the help. It seems to be there is not enough juice(weak starter) to star the car, as rudy said.



Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I start my car without any coolant? DieselHead Diesel Discussion 8 02-07-2004 01:30 PM
HELP ASAP!!! car will NOT start!!! DuckMuck Tech Help 7 04-08-2003 02:50 AM
Starting Problem Jon Hrut Tech Help 12 01-24-2003 06:11 AM
Red and green lights flash on rear view mirror while trying to start car 19542743 Tech Help 1 11-30-2002 08:58 PM
82 300TD A/C problem benchracer Diesel Discussion 15 06-16-2001 09:50 PM



All times are GMT -4. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page