Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 06-20-2012, 04:18 PM
Registered User
 
Join Date: Jan 2003
Location: Matthews, NC
Posts: 1,356
BENZ-LGB

Glad you got the 420 running correctly. The 126 is the only car to have. However, I guess I will have to sell mine. I am old (69), dumb (HS only) and Poor (Never made more that 40K/year in my life). I don't fit in with the average Benz owner.

Paul

__________________
84 500 SEL (307,xxx miles)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Had rough idle, now hard cold start mb82 Tech Help 4 06-26-2004 07:38 PM
rough idle on 420sel SCOTTFISH Tech Help 2 05-03-2004 02:51 PM
Hard cold starting, rough idle 89 300E JAlex Tech Help 1 05-16-2003 03:49 AM
1991 190E 2.6 Consistent rough idle brookspw Tech Help 3 12-30-2001 11:30 PM
80' 450sl rough idle when cold bf Tech Help 1 01-19-2000 09:16 PM



All times are GMT -4. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page