Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2007, 06:56 AM
Registered User
 
Join Date: Jun 2007
Posts: 2
C220D P1227 problem

Being my first post, I'd like to say HI to every respected member of this forum.

I have a C220D '96 car, and after the diagnostics I get the following error:
P1227 Distributor Shaft Position Sensor Y 23/2 | 2
or in german
P1227 Positionsgeber Verteilerwelle Y 23/2 | 2

I am trying to get the description with this error so I can find the part that is damaged and possible solutions.
Any help in this direction is highly appreciated.

Thanks in Advance!
Reply With Quote
  #2  
Old 06-02-2007, 02:15 PM
Registered User
 
Join Date: Jun 2007
Posts: 2
At least a full description of the problem?
Reply With Quote
  #3  
Old 06-02-2007, 02:34 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
This is usually easier if YOU first give us a description of the problem.......

Are you experiencing a no start condition?

FYI -Your engine was never imported to the US. Is it a 202.121 or a 202.193?

Possible issue MAY be the crank position sensor although this is not a common failure on a diesel in my expirience.
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
  #4  
Old 06-02-2007, 03:09 PM
Pistonhead
 
Join Date: Apr 2007
Location: LOUGHBOROUGH, LEICESTERSHIRE
Posts: 13
I agree, more information is required, my German is not good at best and my technical German is worse still, but I think it is the camshaft sensor and not crankshaft sensor.

Please furnish chassis number and engine number. Descibe also more about the fault you are experiencing.
Reply With Quote
  #5  
Old 02-10-2009, 04:38 PM
Registered User
 
Join Date: Feb 2009
Posts: 1
Hy.I have the same problem, and i still didn't fix it.The EPC light apears, and the engine stop's working properly.The diagnostic program, shows the same error "P1227-Distribution shaft position sensor".The car is MB W210 E220 D 1996, engine 604.912 .And the engine starts normaly, the car is running, but the acceleration it's not working properly.The only gear that work's are the 1, 2, and 3 .Hope to solve it soon .Thanks guys . (please excuse my english, it's a little bit rusty) thank's again
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page