Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-07-2001, 04:25 PM
Registered User
Join Date: Nov 2000
Location: Umeň,Sweden
Posts: 46
The engine revs fine to 4.5K then i can hear a strange but not loud sound from the engine.
I can hardly get it to rev more than 5K.
It sound like a leaking sound Fuzzz.
I have changed a lot of things which have helped me on other problems.(OVP,COIL)
I also do regular service air filter,plugs and the others.
The fuel filter is not changed.
The lambda works fine.
My first thought was some kind of fuel delivery problem.
But i have kind of ruled that out because my engine starts perfectly in cold wheather.
Could it be the valve guides or the timing chain.
Have anybody had this type of problem ?

Pelle 300E 4M -89
Reply With Quote
Old 06-07-2001, 06:09 PM
Glen's Avatar enthusiast
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,185
I'd guess a clogged catalytic converter.
Glen Tokuhara
Beauty & the Beast and the wagon that could!
Reply With Quote
Old 06-07-2001, 06:29 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I would definitly change the fuel filter since it hasn't been changed. I had a similar problem, my car started fine, but everything went back to normal after a new fuel filter and spark plugs. Fuel filter might not be your problem, but it's definitly worth a cheap try, and it's good maintenance!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 06-07-2001, 10:40 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Well, Pelle, if you are reaching 5000 rpm, then it's unlikey that it's fuel delivery. You are near the top of the safe rpm range for the M103 motor. You didn't mention whether or not the engine seemed to be breaking up, ie. go stop go stop or perhaps a high speed surge. The sound you are hearing could be a high pressure exhaust leak, associated with high engine speed, which might just point to an obstructed cat. Has the car burned a lot of oil,has it had valve guides,seals done. What is the mileage on the engine? Another thought is the distributor cap and rotor. Have those pieces been replaced or checked?
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
Old 06-08-2001, 05:37 PM
Registered User
Join Date: Nov 2000
Location: Umeň,Sweden
Posts: 46
it is a high speed surge,the car has 150K.
I haven┤t changed cap/rotor.
The guides and the seals have not been done any work on.
I have however checked the rotor/cap and they look okay but i think i will change them anyway.
I had some trouble with the coil and the wire from it to the cap but i have changed them.(misfired)
There are some tapping sound from a bad lifter that comes and goes.
I recently have done an emmission test that was okay.
The high rpm range is not used frequently.
The oil change is done every 6K and i have to fill from low to high after about 3-4K.

Pelle 300E 4M -89
Reply With Quote
Old 09-17-2001, 04:56 PM
Registered User
Join Date: Nov 2000
Location: Umeň,Sweden
Posts: 46
I have finally replaced the cap and rotor.
No difference in the high rpms.
Since i have changed and inspected every electrical component in the ignition system i have to rule it out.

Is it possible that the guides/seals can begin to vibrate or something on high rpms ?

What happens if a/the fuel injector(s) wears/clogges up.

If i have a clogged up cat and it is the leaking that i can hear - where is the leak ?

The sound is coming more from the driver side of the engine.

Well , i have to fix this problem because my wife is complaining about it.

Reply With Quote
Old 09-17-2001, 10:11 PM
Registered User
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
wow! your wife really drives fast. i cruise at about 4000 rpm
max which is equivalent to 140-150 kms/ hrs. oh, i see you
are from sweden, obviously different driving speed standard.

i' ll stay tuned to what may be your problem, since i suspect
i may have a clogged cat, too!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle 300E -88 (Have preformed search) Sundman Tech Help 28 06-21-2004 03:47 AM
300e Door Panels....All 4 Tan and Front Blue FS!! 6cndmbz Mercedes Used Parts For Sale & Wanted 0 06-13-2004 01:32 AM
Will '93 300E 2.8 seats fit a '88 300E? y2kimmel Tech Help 2 04-29-2004 07:00 PM
300E High idle after revving and 10mpg royaiii Tech Help 0 10-29-2002 05:47 PM
86 300e gas fowled plugs, and high idle wesley winkle Tech Help 1 10-27-2002 10:30 PM

All times are GMT -4. The time now is 08:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page