Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-11-2007, 02:24 PM
Registered User
 
Join Date: Nov 2002
Location: Frankfort, Il.
Posts: 264
Window Problems

89 300TE, left the drivers power window down last night, got in this am and pushed the switch and nothing, all 4 controls for the windows are dead, also the switches in the rear doors are dead. Checked all fuses and they are fine, had to jump the window lift motor to raise the window. Any ideas where to start?? Is there a relay that controls all 4 windows??
Thanks, kchemers

__________________
'05 Ford Escape 100,000 miles
'87 560SL 92000 miles
'89 300TE 199,000 miles
'02 Audi TT 100,000 miles
'00 Ford Excursion V-10 121000 miles
'92 Mercury Capri 100000 miles
'02 BMW 325XI 60000 miles
'92 230CE 160000
'87 BMW 535SI 160,000 miles
'93 Rinker Captiva 209
5 Kids
2 Dogs
1 Wife
Reply With Quote
  #2  
Old 06-12-2007, 12:32 AM
Registered User
 
Join Date: Nov 2002
Location: Frankfort, Il.
Posts: 264
window problems

please any ideas out there?
__________________
'05 Ford Escape 100,000 miles
'87 560SL 92000 miles
'89 300TE 199,000 miles
'02 Audi TT 100,000 miles
'00 Ford Excursion V-10 121000 miles
'92 Mercury Capri 100000 miles
'02 BMW 325XI 60000 miles
'92 230CE 160000
'87 BMW 535SI 160,000 miles
'93 Rinker Captiva 209
5 Kids
2 Dogs
1 Wife
Reply With Quote
  #3  
Old 06-12-2007, 09:05 AM
Seeking Knowledge
 
Join Date: May 2007
Location: Fitchburg, MA
Posts: 45
I had the same issue, actually, when i got the car only one window worked. Now, i got one more to work after cleaning the switches. the ones on the driver side were totally dead before. After i cleaned the switches I can now hear the motor move. I don't know if that will help you, there is a DIY article on this site to clean out your window switches. it was pretty easy. Now i gotta figure out what's wrong with the motors .

Here is the link: http://www.peachparts.com/Wikka/SwitchRefurb

Good Luck

__________________

-Dominicanvirus

Last edited by Dominicanvirus; 06-12-2007 at 10:09 AM. Reason: add a link
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page