Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-10-2001, 10:52 PM
Registered User
Join Date: Apr 2000
Posts: 63
When I use A/C everything work fine, but 30 sec. after it's turned off, it begins to stink really bad. What do I do ? Change expensive charcoal filter or clean the evaporator ? Service supposedly doesn't change them under warranty. Is that true ?
'58 190SL 74K Sold
'63 190SL 137K
'64 230SL 187K Sold
'66 230SL ZF5 113K Available
'68 280SL ZF5 54K
'82 300D 167K Sold
'84 300D 143K
'98 S500 95K SOLD
'03 ML350 43K
'07 E63 18K
Reply With Quote
Old 06-10-2001, 11:30 PM
JimF's Avatar
'94 S500: only 793 sold!
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,924
Charcoal filters . . . there's two!

As I recall, the pre-filter get serviced at 90K or 100K miles. But don't recall seeing anything about the main filter.

Just changed my S500 charcoal filters (95K miles); the pre-filter, which is easy, cost about $100.

And the main filter. This is difficult to get out. Cost also about $100.

But no stink! The prefilter was very WET because the air plenum drain hose got diverted and drained into the the pre-filter cavity. It had a damp smell but was not detectable in the car.

Good luck, it's a job.
Regards . . . . JimF
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
Old 06-11-2001, 12:04 AM
Senior Member
Join Date: Mar 2001
Location: Accokeek, MD
Posts: 683
You may have a dead mouse in there somewhere.

1993 190E 2.3
2000 Toyota 4x4 Tundra
Reply With Quote
Old 06-15-2001, 12:46 PM
Posts: n/a

I work at a Ford garage, when we have "stinky" AC problems, we remove the evaporator and flush the inside and outside with bleach and a Motorcraft 'disodorizer' part # YN-18. Available at any Ford store for about seven bucks. Its a pain and it sucks but it does work.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C readouts on E430 and S500 Ken Griffith Tech Help 0 06-28-2004 03:22 PM
94 S500 Coupe A/C PUSHBUTTON TURNS OFF... BENZ TEK Tech Help 0 05-13-2004 08:47 PM
1995 S500 w140 A/C problem intermittent mike345 Tech Help 2 08-10-2003 01:35 AM
S500 A/C leaking? please help.. slai1112 Tech Help 9 05-25-2002 09:24 PM
S500 a/c pressures questions fenix Tech Help 6 09-24-2001 01:36 AM

All times are GMT -4. The time now is 07:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page