Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-27-2001, 11:20 AM
Registered User
Join Date: Oct 2000
Location: Nashville, TN USA
Posts: 16
I had a problem with my 86 420 SEL a couple of mos back- after having a MB reman compressor installed, my lft instrument cluster would die, and the compressor would not kick on.
All fuses were ok. I followed Benzmac's advice and replaced all of the fuses in the box- problem solved.

My mother now has the car, and calls me this morning and tells me that now the gas gauge does not work, and again, the a/c compressor is not kicking on. My mother lives 2+ hours from a dealer, and the nearest independent is 1.5 hrs away. Where do I begin? Again, all fuses are ok. Is the fuel level sending unit on the same circuit as the a/c compressor kick on?

Thanks in advance
2000 ML430 86k
2000 C280 Sportline 100k
'86 420 SEL 178k
'91 Audi 100 179k
'88 BMW 750il 167k
'83 300 SD 167k (sold)
'79 300 D 78k (sold)
Reply With Quote
Old 06-27-2001, 09:23 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The contact where that fuse rides has heated up over time and lost it spring. This will result in wear on the top of the fuse. You will have to replace the fuse again for now and then eventually solder in a remote fuse holder.

Donnie Drummonds
Reply With Quote
Old 06-27-2001, 11:55 PM
Ashman's Avatar
Service Advisor
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
I have had to solder an external fuse holder in my fathers rolls. The one ont he board was busted, and that part on that car is not cheap...

Follow Benzmac's advice...again.

'92 300CE - Sold
2004 C240 - C7 Wheels
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
81 240D electrical problems fang Diesel Discussion 6 10-17-2004 11:19 PM
Electrical Problems WaveRunr Tech Help 1 03-02-2004 06:31 PM
1995 C280 Electrical Problems David C Klasse Tech Help 14 04-14-2003 08:31 PM
1989 560SL electrical problems Cg Gunther Tech Help 1 03-21-2003 07:40 AM
1999 E300D Electrical Problems searaypaul Diesel Discussion 11 05-10-2002 05:52 PM

All times are GMT -4. The time now is 01:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page