Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2001, 10:31 PM
Jax,FL Chris
Guest
 
Posts: n/a
I have a 78 300D with an A/C problem.
6 months ago the A/C idler pulley bracket would not tighten any more due to a stripped hole. Prior to this the A/C worked fine. I replaced the bracket and pulley and the air worked fine for about 1/2 an hour then the fan and compressor stopped. I switched to defrost and the fan and compressor both came on as usual except the air never went to high heat as it does when on defrost. This worked for another 10 minutes with cold air on defrost then everything stopped again. Came home and the blower fuse and the "A/C switchover/idle control fuses were both blown.
Replaced them, next day same thing all over again.
I also replaced a leaking trunk diaphragm at the same time as the pulley as the vacuum leak would not allow the fan to blow through the front panel vents. Not sure if this would have anything to do with the problem or not.
Any advise on this would be great, it is 94 degrees here in FLA and I just know the power windows will decide to quit pretty soon too!!!
Reply With Quote
  #2  
Old 07-04-2001, 10:15 AM
Jax,FL Chris
Guest
 
Posts: n/a
78 300D A/C Problem

The A/C problem seems to be solved.
The blower fan motor was on it's way out and was causing
an overload and blowing the fuse. Since the fan was not working, some kind of safety would not let the compressor come on.
I replaced the fan and it is all working fine.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C System Leak - 84 300D Turbo Diesel 84W123DT Diesel Discussion 2 08-18-2003 03:33 PM
A/C problem Joko Tech Help 5 08-12-2003 01:44 PM
a/c problem in C230K BillH Tech Help 12 05-05-2003 05:31 PM
Intermitent A/C Problem ? Aija Tech Help 8 07-22-2002 12:36 PM
A/C problem has got me hot!!! Matt201 Tech Help 1 08-01-2001 12:39 AM



All times are GMT -4. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page