Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-20-2001, 08:19 PM
maustin
Guest
 
Posts: n/a
I think I have an O.K. mechanic, but I just can't quite understand everything that's going on with my benz. My "86" 420SEL has been in the shop for well over a month now because my speedometer just stopped working. The other gauges in the dash work fine, just not the speedometer. The mechanic says I need a speedometer or as he put it a "Speed Control," and also an idler. He explained that everything works off the computer. Can the computer have a glitch? He has been unsucessful in locating these parts to complete the job. Is my benz ready for the salvage yard? I tried to email a picture of the benz with this post, but it didn't work. What would you guys do? I have called a few other MB shops and they have not gotten back with me.
Reply With Quote
  #2  
Old 07-20-2001, 09:33 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,773
Something does not sound right here. At the worst it should have just been a removal of the speedo and send to VDO of America for rebuild/rework. At the least it should have been a new speedo cable. Someone with more experience than me will have to speak for the "driven" end of the speedo cable but I have never heard or seen of that end going bad.
__________________
Jim
Reply With Quote
  #3  
Old 07-20-2001, 09:33 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
Where are you located?

The partsshop or fastlane on this site can probably get the parts needed. you can check by clicking the links above.

If you are in Los Angeles, Check out Mr. MB Motors in Tarzana. he is a very good mechanic.

Look in the good mb shopd section on this discussion forum for a shop in your area. check the search function of the site as well to see if you can find some help for the problem.

Sounds to me like you don't need to send it to the salvage yard if thats the only problem. These cars easily last for years and years.

If the car runs good otherwise, it should be fixable.

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #4  
Old 07-20-2001, 10:28 PM
maustin
Guest
 
Posts: n/a
The speedometer problem is the only thing that is keeping me from driving it, everything else works fine. The thing that really bothers me the most is that I located one here at Mercedes Shop for $500. I explained to the mechanic that I could get a speedometer if that was indeed the only major problem. He just seems "wishy-washy" to me. I listened to ever little word he said to me regarding the problem and I am just not feeling too good about it. For now, my Benz remains redlined and I am wanting to correct this problem as soon as possible. I am on the east coast, in south Georgia. More suggestions would be greatly appreciated at this point. Thank you Engatwork and Ashman.
Reply With Quote
  #5  
Old 07-22-2001, 09:17 AM
Registered User
 
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
Isn't Mercedesshop opening a tech/repair shop in Georgia? I would head over there if and when they do. Otherwise find another mechanic. I had two different mechanics tell me to junk my 1986 420SEL because they couldn't find the cause of a rough idle. They said (without doing any tests or even taking the valve covers off) that I needed a valve job that would cost 5 grand. Then they said they had seen valve jobs on these cars go as high as 13 grand because things inevitably break. I found myself a good mechanic who diagnosed the problem, replaced my fuel distributor and injectors and the car runs as smooth as glass now. There is likely a better answer for you out there.
__________________
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote
  #6  
Old 07-22-2001, 10:20 AM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Steve Brotherton is in Gainesville, Fl and they work on VDO equipment. Give them a call or visit their site at http://www.continentalimports.com. Something smells fishy with your mechanic...
__________________
J.H.
'86 300E
Reply With Quote
  #7  
Old 07-22-2001, 09:39 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
Spedo dead? yunkyard bound maybe not

Log on to E-Bay and search for 126 instrument clusters. Or Call some junk yards in your area. There are lots of these available for less than $100 for the entire instrument cluster.
Reply With Quote
  #8  
Old 07-24-2001, 12:44 PM
maustin
Guest
 
Posts: n/a
After speaking with several mechanics, several say it may not be the speedo, it may just be a sensor. Is there some kind of test that I can have performed to be sure I am not buying a speedo when all I need is a sensor? Everything continues to work in the dashboard, except the speedometer needle. What is the difference between a speedo and a speedo head? (Another mechanic told me I needed a speedo head.) I am trying to understand the mechanic jargon. Some say this, some say that. Can somebody explain it to me in plain english? Thanks!
Reply With Quote
  #9  
Old 07-24-2001, 02:25 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,773
maustin - does the odometer work (the part that registers miles)? Is it just the speedometer needle that does not work? I imagine the needle and the odometer get their signal from the same sensor so if the odo works and the needle doesn't then I would figure it is in the speedo itself otherwise, if neither are working it may very well be the sensor.
For the techs - where is the sensor physically located on the 420SEL?
__________________
Jim
Reply With Quote
  #10  
Old 07-24-2001, 03:01 PM
maustin
Guest
 
Posts: n/a
Hi! Jim
Yes! The odometer (where the miles turn), still works fine. The speedo needle is the only thing dead. I understand that the odometer is getting a signal, so it works, as well as the other components in the dash. So, it has to be the speedo that's bad. I am really learning allot about speedo's. Where is the trouble coming from, the sensor or computer? Yep, that is a good question. Where is it located? I think it has to be in the speedo or on the computer board in the speedo. Right???
Reply With Quote
  #11  
Old 08-24-2001, 01:08 AM
maustin
Guest
 
Posts: n/a
Talking

Well, I finally have the speedo problem fixed. I had to remove it a second time to send it back to the VDO folks because the odometer stopped turning. Every in that area is squared away now! My 420SEL should be named "Christine". (Remember the car named Christine?) It's one thing after another. I was driving in busy traffic today, and all of the sudden the alarm just started honking! Man-O-Man, did I get some looks! I was so embarrassed! Somebody yell, "You should have brought an american car!" I had to pull over and insert the key in the door lock to stop it. Can anybody with a 420SEL give me some feedback on this one? What's up with this wacky alarm? Also, how do I idle the RPM's from 11000 to 6000 RPM's? My 420 is burning allot of gas. I know this is a big sedan, but I think the high idle has something to do with this also. Is it something I can do without having to take it to a mechanic? Once under the hood, where do I look? What majic screw do I turn???
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fintail in a salvage yard bikis Vintage Mercedes 0 01-02-2005 08:28 PM
MA or NH Salvage Yard Advice Needed ak300td Diesel Discussion 8 10-19-2004 04:43 PM
Good PA Salvage Yard JPL Open Discussion 4 06-13-2002 11:48 PM
Salvage yard in TN LoveLEE143 Tech Help 4 07-22-2001 02:53 PM
Salvage yard engines shoe Tech Help 11 09-09-2000 09:35 AM



All times are GMT -4. The time now is 07:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page